Код программы:
var a:integer;
begin
write('Введите возраст автовладельца: ');
readln(a);
if (a > 40) then begin
writeln('Выберите место эксплуатации:');
writeln('1. Город');
writeln('2. Сельская местность');
readln(a);
if (a = 1) then begin
write('Введите стаж: ');
readln(a);
if (a > 10) then
writeln('Страховать')
else
writeln('Не страховать')
end
else
writeln('Страховать')
end
else begin
writeln('Езда без аварий?');
writeln('1. Да');
writeln('2. Нет');
readln(a);
if (a = 1) then
writeln('Страховать')
else begin
writeln('Выберите тип автомобиля:');
writeln('1. Минивэн');
writeln('2. Спорткар');
readln(a);
if (a = 1) then
writeln('Страховать')
else
writeln('Не страховать')
end;
end;
end.
Поделитесь своими знаниями, ответьте на вопрос:
Укажите наименьшее пятизначное число x, при вводе которого алгоритм печатает 26391. паскаль: var x, y, a, b: integer; begin readln(x); a: =0; b: =0; y: =1; while x > 0 do begin if (x mod 10) mod 2 = 0 then a: = a*10 + x mod 10 else begin y: = y*10; b: = b*10 + x mod 10 end; x : = x div 10 end; a: = a*y + b writeln(a); end.
2. Немного изменим ваш код и получим искомое значение x
Искомое число х = 16293
var
x, y, a, b, k: integer;
begin
k:=10000;
repeat
x:=k;
a := 0; b := 0; y := 1;
while x > 0 do
begin
if (x mod 10) mod 2 = 0
then
a := a * 10 + x mod 10
else begin
y := y * 10;
b := b * 10 + x mod 10
end;
x := x div 10
end;
a := a * y + b;
k := k + 1;
until a = 26391;
writeln(a:8, k-1:8);
end.