innesagrosheva22
?>

Используя функцию round, int , frac, применив их к некоторому вещественному х, округли число до ближайшего целого числа (составить программу в паскаль)

Информатика

Ответы

allo22-27
Если до ближайшего целого, то можно так:
var
  a: real;

begin
  write('Введите вещественное число A: ');
  readln(a);
  writeln(round(a));
end.
angelina-uj1350
Современный компьютер может обрабатывать числовую, текстовую, графическую, звуковую и видео информацию. Все эти виды информации в компьютере представлены в двоичном коде, т. е. используется алфавит мощностью два (всего два символа 0 и 1). Связано это с тем, что удобно представлять информацию в виде последовательности электрических импульсов: импульс отсутствует (0), импульс есть (1). Такое кодирование принято называть двоичным, а сами логические последовательности нулей и единиц - машинным языком. Суть кодирования заключается в том, что каждому символу ставят в соответствие двоичный код от 00000000 до 11111111 или соответствующий ему десятичный код от 0 до 255.
egoryandiana3727283
1) один символ (например буква) = 1 байт. 1 байт = 8 бит (или по другому - 8 разрядов). Некоторые символы, например иероглифы не умещаются в 1 байт потому что их много, поэтому для них используют не один байт, а больше. Если для символа нужно больше 8 бит, то прибавляют не недостающее число битов, а удваивают число байт. Поэтому буквы (символы) или 8-ми разрядные (1 байт), или 16-ти разрядные (2 байта), или 32-х разрядные (4 байта).
2) МАМА - это 4 обычных символа, или 4 байта (32 бита).
3) один байт, или 8 бит.
4) 15 байт - количество всех букв + пробелы + точка. Или 120 бит.
5) 21 байт, или 168 бит (все буквы + пробел + точка).
6) 7 букв = 7 байт.
7) 20 х 40 = 800 символов/страница. 2 страницы = 1600 символов. 1600 символов = 1600 байт, или 1600 х 8 = 12800 бит.
8) 20 байт.
9) большой латинской "ай" - "I".
10) латинская буква "N".
11) маленькая латинская "ай" - "i". Из формулы Хартли N=2^{i}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Используя функцию round, int , frac, применив их к некоторому вещественному х, округли число до ближайшего целого числа (составить программу в паскаль)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Mark-Petrovich
ovalenceva77
alapay
Plotnikovangav
cheshirsky-kot
Буянто1346
waspmoto6188
fedoseevalyubov
whiskyandcola
Хачатурович978
ПолухинаТененева565
Нана_Елена
remontsalarievo2
Neveselova
orgot9