kondrashovalf6404
?>

Составить программу вычиcления объема цилиндра при радиусах r и высоте h, по формуле v=p*r*r*h

Информатика

Ответы

Бочкова_Елена203

var

p,r,h: real;

begin

readln(p,h);

v: =pi*sqr(r)*h;

writeln(v: 5: 3);

end;

Boykoyelena

program pr;

var v, p, r, h: real;

begin

writeln('введите r');

readln(r);

writeln('введита h');

readln(h);

v: =3,14*r*r*h;

writeln('v=, v');

readln;

end.

yakushkinayuliya

using system;

using system.collections.generic;

namespace num

{

class program

    {

        static void main(string[] args)

        {

            console.writeline("введите количество элементов: ");

            int n = int32.parse(console.;

            console.writeline("введите элементы через enter: ");

            list< int> numbers = new list< int> ();

            for(int i = 0; i < n; ++i)

            {

                int temp = int32.parse(console.;

                numbers.add(temp);

            }

            console.writeline("элемены значения которых с их индексом: ");

            for (int i = 0; i < n; ++i)

            {

                if (numbers[i] == i)

                    console.write(numbers[i] + " ");

            }

            console.writeline();

            console.readkey();

        }

    }

}

Грудинин604

идея компьютера была предложена чарльзом бэбиджем (charles babage) в середине девятнадцатого века. его механическая «аналитическая машина» так и не смогла по-настоящему заработать, потому что технологии того времени не удовлетворяли требованиям, необходимым для изготовления нужных деталей точной механики. конечно, никакой речи об операционной системедля этого «компьютера» не шло. настоящее рождение цифровых вычислительных машин произошло вскоре после окончания второй мировой войны. в середине 40-х были созданы первые ламповые вычислительные устройства. в то время одна и та же группа людей участвовала и в проектировании, и в эксплуатации, и в программировании вычислительной машины. это была скорее научно-исследовательская работа в области вычислительной техники, а не использование компьютеров в качестве инструмента решения каких-либо практических из других прикладных областей. программирование осуществлялось исключительно на машинном языке. не было никакогосистемного программного обеспечения, кроме библиотек и служебных подпрограмм, которые программист мог использовать для того, чтобы не писать каждый раз коды, вычисляющие значение какой-либо функции или стандартным устройством ввода-вывода.операционные системывсе еще не появились, все организации вычислительного процесса решались вручную каждым программистом с пульта , который представлял собой примитивное устройство ввода-вывода, состоящее из кнопок, переключателей и индикаторов. с середины 50-х годов начался новый период в развитии вычислительной техники, связанный с появлением новой технической базы. выросло быстродействиепроцессоров, увеличились объемыоперативнойи внешней памяти. компьютеры стали более надежными, теперь они могли непрерывно работать настолько долго, чтобы на них можно было возложить выполнение действительно практически важных . но выполнение каждой программы включало в себя большое количество работ (загрузка, запуск, получение результирующей программы в машинных кодах и т. поэтому для организации эффективного совместного использования были введены должности операторов, профессионально выполнявших работу по организации вычислительного процесса для всех пользователей этого центра.

но как бы быстро и надежно ни работали операторы, они никак не могли состязаться в производительности с работой устройств компьютера. а поскольку процессорпредставлял собой весьма дорогое устройство, то низкая эффективность его использования означала низкую эффективность использования компьютера в целом. для решения этой проблемы и были разработаны первые системыпакетной обработки, которые автоматизировали всю последовательность действий оператора по организации вычислительного процесса. ранние системыпакетной обработкиявились прообразом современныхоперационных систем, они стали первыми системными программами, предназначенными не для обработки данных, а для вычислительным процессом.

в ходе реализации систем пакетной обработкибыл разработан формализованный язык , с которого программист сообщал системе и оператору, какие действия и в какой последовательности он хочет выполнить на вычислительной машине.

ранние системы пакетной обработки значительно сократили затраты времени на действия по организации вычислительного процесса, а значит, был сделан еще один шаг по повышению эффективности использования компьютеров. однако при этом программисты-пользователи лишились непосредственного доступа к компьютеру, что снижало эффективность их работы — внесение любого исправления требовало значительно больше времени, чем при интерактивной работе за пультом машины.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычиcления объема цилиндра при радиусах r и высоте h, по формуле v=p*r*r*h
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Chervonnaya-Aleksei
ilma20168
office426
Daletskaya Sergei1121
Goldglobe
chulki-kupit
Vladimirovich Aleksandr1889
salesrawtogo
komarov-dmitriy
Bobkov
Panda062000
fursov-da
zotovinbox468
Fruktova Gazaryan
emartynova25