zaotar2008
?>

Вначале выполнения этого в элементе массива с индексом i находилось число i (i = 1, …, 32), т. е. a[1] = 1, a[2] = 2 и т. д. чему будет равно значение переменной s после выполнения данной программы? s: =0; n: =32; for i: = 2 to n do begin s: =s+3*(a[i]-a[i-1]); end; 1) 93 2) 90 3) 31 4) 30

Информатика

Ответы

orange-salon-job77
Тело цикла будет выполнено 31 раз. Следовательно переменная s станет равна 93
Дил1779

Объяснение:

#include <iostream>

using namespace std;

long double fact(int N)

{

   if(N < 0) // если пользователь ввел отрицательное число

       return 0; // возвращаем ноль

   if (N == 0) // если пользователь ввел ноль,

       return 1; // возвращаем факториал от нуля - не удивляетесь, но это 1 =)

   else // Во всех остальных случаях

       return N * fact(N - 1); // делаем рекурсию.

}

int main()

{

   int N;

   setlocale(0,""); // Включаем кириллицу

   cout << "Введите число для вычисления факториала: ";

   cin >> N;

   cout << "Факториал для числа " << N << " = " << fact(N) << endl << endl; // fact(N) - функция для вычисления факториала.

   return 0;

}

ольга1801

1) В столбце Е для каждого учащегося вычислим сумму по двум предметам, если это ученик школы округа «Центральный». Для ученика другого округа ячейка будет содержать пустую строку. В ячейку Е2 запишем формулу =ЕСЛИ(В2=«Центральный»; С2+D2; "") Скопируем формулу во все ячейки диапазона ЕЗ:Е273. Благодаря использованию относительных ссылок в столбце Е непустые значения строк 2−267 будут равны суммам учеников школ округа «Центральный». Для того чтобы найти наименьшую сумму, в ячейку G1 внесём формулу =МИН(Е2:Е267).

2) Для ответа на второй вопрос в дополнительной ячейке, например в НЗ, найдём количество участников, набравших по физике менее Это можно сделать различными в том числе при функции =СЧЁТЕСЛИ(С2:С267; "<70"). Выразим полученное значение в процентах от общего числа участников тестирования. Результат запишем в ячейку G3: =НЗ/266*100.

ответ: 1) 68; 2) 90,2.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вначале выполнения этого в элементе массива с индексом i находилось число i (i = 1, …, 32), т. е. a[1] = 1, a[2] = 2 и т. д. чему будет равно значение переменной s после выполнения данной программы? s: =0; n: =32; for i: = 2 to n do begin s: =s+3*(a[i]-a[i-1]); end; 1) 93 2) 90 3) 31 4) 30
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Тимур Андраниковна634
Бурмистрова-Ирина660
molchanovaelena284
veniaminsem
Zeegofer
byfetvostochniy
titancore
m-illarionov
sancity997124
Смирнов_Андрей691
ekaterinkat
ilyushin-e
ba5-m
Borg Fedak1162
pnat1235