ГазалиеваКозак
?>

Написать программу вычисления сопротивления электрической цепи, состоящей из 2х сопротивлений. сопротивления могут быть соединены параллельно или последовательно. как должен быть реализован вывод результата на экран: выберите тип соединения: 1 – последовательное, 2 - параллельное введите 1ое сопротивление введите 2ое сопротивление сопротивление цепи= … ом

Информатика

Ответы

vladexi
Вот в придложенном файле работающая программа, только я пока не догнал как ее коруглить, чтобы в ответе не было число + куча нолей в степени Е+00, а было просто числа например 2.5 или 3,7 или просто 5 или 7
tetralek
1 2 3 4 5 6 7 program proba; uses crt, graph; var begin write('hello'); readln; end.при alt+F5
выводит черный экран, и ждет нажатия любой клавиши.
Как будто readln работает а writeln нет.
Сначало пробовала TP7, потом попробовала BP7, ситуация и там и там одинаковая.
Раньше, где-то пол года назад все работало.
А сейчас просто черный экран.

И программы написанные раньше также
 не работают, черный экран и все.
Может кто сталкивался с подобным.
На компе также установлен, delphi3, и delphi7.
Только в университет работу нужно сдавать именно в паскале.
sveta740450

Итак. Мы имеем строку из 72 пятерок.

Сначала все пятерки заменяются на тройки (приоритетным действием у нас является замена первого вхождение трех идущих подряд пятерок тройками, а т.к. 72 кратно трем, то преобразованная строка будет состоять только из троек). После этого у нас остается строка, состоящая из 24 троек.

555 555 555 555 ... 555 => 333 333 333 333 333 333 333 333

Затем происходят такие действия: три последовательно идущие тройки заменяются на пятерки, а после того как таких пятерок будет три, они заменятся на одну тройку. Следственно 9 троек заменяются на одну. После проведение данных действий у нас остается 24-9+1-9+1=16-9+1=8 троек.

333 333 333 333 333 333 333 333

555 333 333 333 333 333

333 333 333 333 333 3

555 333 333 3

333 333 33

Так как мы уже не можем получить заменой троек хотя бы три пятерки, то первые вхождения трех подряд идущих троек заменяются пятерками.

333 333 33

5 333 33

5533

ответ: 5533

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу вычисления сопротивления электрической цепи, состоящей из 2х сопротивлений. сопротивления могут быть соединены параллельно или последовательно. как должен быть реализован вывод результата на экран: выберите тип соединения: 1 – последовательное, 2 - параллельное введите 1ое сопротивление введите 2ое сопротивление сопротивление цепи= … ом
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Михайловна-Гусева350
Николаевич
vera2job7
nadlen76
ИП Жанара
Mariya dmitrievna
denisov4
Daletskaya982
Наталья_Васищев
PivovarovaIlina1437
rendikalogistic
Владимирович_Слабый
sergeevich
happygal5224
КузменковаЖигулин