evgeniishulov4696
?>

Все сделать в паскале. дан массив из 12 элементов, в котором есть положительные и отрицательные чи сла (ноль тоже есть): а1=5, а2=4, а3=-3, а4=1, а5=0, а6=-4, а7=, а8=25, а9=-8, а10=-5, а11=-17, а12=-1. составьте программу, в которой 1 вариант: все отрицательные числа меняются на «1», все положительные на «-5», нулевые не трогаются. вывести на экран исходный и полученный массив как в классе; дополнительная оценка, если появляется дополнительная возможность ввода своих чисел с клавиатуры с клавиатуры.

Информатика

Ответы

Цветкова
Program mm;
var a:array[1..12] of integer;
begin
for i:=1 to 12 do begin
а[1]:=5;
 а[2]:=4;
 а[3]:=-3;
 а[4]:=1;
 а[5]:=0;
а[6]:=-4;
 а[7]:=(у тебя не написано);
 а[8]=25;
 а[9]=-8;
 a[10]=-5;
 а[11]=-17;
 а[12]=-1;
end;
writeln('Вот исходный массив');
for i:=1 to 12 do writeln('A[',i,']=',a[i]); 
for i:=1 to 12 do begin
if (A[i]<0) then a[i]:=1;
if (a[i]>0) then a[i]:=-5;
end;
writeln('Вот полученный массив');
for i:=1 to 12 do writeln('A[',i,']=',a[i]); 
writeln(' Введите 12 чисел');
for i:=1 to 12 do readln(A[i]);          (это доп оценка)
end.
Anna Artem
Каждый символ в кои-8 имеет объем информации 1 байт. всего текста 60*30 = 1800 байт на каждой странице. растровое изображение передает не более 8 = 2^3 цветов, значит, на кодировку цвета используется 3 бита. размер каждого рисунка 120*240*3 = 86400 бит = 10800 байт. а рисунков 2 на каждой странице. таким образом, каждая страница содержит 2*10800 + 1800 = 23400 байт. модем со скоростью передачи 28800 бит в сек передал документ за 5 сек. значит, он передал 28800*5 = 144000 бит = 18000 байт. но это меньше, чем находится на одной странице. вывод: у вас ошибка в условии.
galinasemyan689
Const   n = 50; // количество чиселvar   k: array [1..n] of integer;   i, j, n1, n2, minr, a, b: integer; begin   writeln(n, ' ', ': d');   a : = random(1000);   b : = random(1000);   minr : = 10000;   for i : = 1 to n do       k[i] : = a + random(b);   for i : = 1 to n do       for j : = 1 to n do           if ((abs(k[i] - k[j])) < minr) and (k[i] < > k[j]) then           begin               minr : = abs(k[i] - k[j]);               n1 : = i;               n2 : = j;           end;   writeln(n1, ' ', n2); end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Все сделать в паскале. дан массив из 12 элементов, в котором есть положительные и отрицательные чи сла (ноль тоже есть): а1=5, а2=4, а3=-3, а4=1, а5=0, а6=-4, а7=, а8=25, а9=-8, а10=-5, а11=-17, а12=-1. составьте программу, в которой 1 вариант: все отрицательные числа меняются на «1», все положительные на «-5», нулевые не трогаются. вывести на экран исходный и полученный массив как в классе; дополнительная оценка, если появляется дополнительная возможность ввода своих чисел с клавиатуры с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Поликарпова-Мазурова
skvorec3424
shymilin19951783
ЕлизаветаВладимирович
annasv8
fedoseevgleb
mir5552
Yelena Kotova
Кирилл-Анна1023
sanseth5
ynikolaev2657
lider123
nickcook424
puma802
moonligh3560
▲