Сулейманова
?>

Заданы две клетки шахматной доски. если они покрашены в один цвет, то выведите слово yes, а если в разные цвета — то no. программа получает на вход четыре числа от 1 до 8 каждое, номер столбца и номер строки сначала для первой клетки, потом для второй клетки.

Информатика

Ответы

Stasyadoma
Клетка будет черной, если номер столбца и номер строки будут одновременно четными или нечетными. Белыми, если один из них четный, а второй нечетный.
var a,b,c,d,t,k:integer;
begin
k:=0;
t:=0;
read(a);
read(b);
read(c);
read(d);
if (a mod 2=0) and (b mod 2=0) or (a mod 2=1) and (b mod 2=1) then
t:=1;
if (c mod 2=0) and (d mod 2=0) or (c mod 2=1) and (d mod 2=1) then
k:=1;
if t<>k then
writeln('NO')
else
writeln('YES');
end.
Darya Aleksei1173

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

#include "stdafx.h"

#include "stdio.h"

#include <time.h>

#include <stdlib.h>

class vector

{

private:

int* m;

int size;

public :

vector(int n = 0);

vector(const vector &vector2);

~vector();

};

vector::vector( int n )

{

if (n < 0) n = 0;

size = n;

m = new int[n];

if(!m)

printf("Error");

else

m = NULL;

}

vector::vector(const vector &vector2)

{

size = vector2.size;

m = new int [size];

for(int i = 0; i<size;i++)

m[i] = vector2.m[i];

printf("kopia stvorena !");

}

vector::~vector()

{

delete[] m;

}

vector(int *m, int size)

{

srand(time(NULL))

if(!m)

printf("error")

else

for(int i = 0; i < size; i++)

m[i] = rand()% 99;

}

int main()

{

vector v1(45),

system("pause");

return 0;

}

evsmorodina

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

39

40

41

42

43

44

45

46

47

48

49

50

51

52

53

54

55

#include "stdafx.h"

#include "stdio.h"

#include <time.h>

#include <stdlib.h>

class vector

{

private:

int* m;

int size;

public :

vector(int n = 0);

vector(const vector &vector2);

~vector();

};

vector::vector( int n )

{

if (n < 0) n = 0;

size = n;

m = new int[n];

if(!m)

printf("Error");

else

m = NULL;

}

vector::vector(const vector &vector2)

{

size = vector2.size;

m = new int [size];

for(int i = 0; i<size;i++)

m[i] = vector2.m[i];

printf("kopia stvorena !");

}

vector::~vector()

{

delete[] m;

}

vector(int *m, int size)

{

srand(time(NULL))

if(!m)

printf("error")

else

for(int i = 0; i < size; i++)

m[i] = rand()% 99;

}

int main()

{

vector v1(45),

system("pause");

return 0;

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Заданы две клетки шахматной доски. если они покрашены в один цвет, то выведите слово yes, а если в разные цвета — то no. программа получает на вход четыре числа от 1 до 8 каждое, номер столбца и номер строки сначала для первой клетки, потом для второй клетки.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

zipylin
badalovao256
Илья_Ветклиники1655
AndrukhovichKonovalov
alyonafialka
rublevaoe392
Kulikovvl9
Vyacheslavovna1867
irina-mic
Vadim443
ekater01806
Татьяна-Мария
ДеречинскийИрина1149
Олег1105
arammejlumyan