Герасименко
?>

Дано n случайных чисел в диапазоне от -3 до 3. вычислите, сколько из них не с 0. составить программу, используя цикл for. для случайных ч исел используйте функцию random. n определяет пользователь. числа вывести на экран.

Информатика

Ответы

horst58
Var a,i,n,k : integer;
Begin
  randomize;
  Readln(n);
  for i:=1 to n do begin
    a:=random(7)-3;
    if a=0 then k:=k+1;
    writeln(i,' число = ',a);
  end;
  Writeln('Количество 0: ',k);
end.
svetarakityanskaya

TXT - В *.txt-файле содержится только текстовая информация и ничего больше.

RTF - Универсальный кросс-платформенный формат для хранения текстовой информации. Сохраняет данные форматирования, позволяет производить вставку дополнительных объектов: формул, таблиц, сносок и др.

DOC - Имеют возможности сохранения форматирования, стилевого оформления, вложения картинок и других объектов в текст, а также поддержку гиперссылок.

DOCX - Усовершенствованный и лицензированный формат от Microsoft. Представляет собой следующий этап формата *.doc.

HTML - был разработан специально для создания веб-страниц, но благодаря своей универсальности, удобству и небольшому размеру стал широко использоваться для хранения текстовых данных.

PDF - Этот формат стал стандартом для обмена документами.

ODT - Поддерживает большую часть форматирования что и «DOCX», включая вставку изображений, таблиц и гиперссылок.

Объяснение:

pechinin

TXT - В *.txt-файле содержится только текстовая информация и ничего больше.

RTF - Универсальный кросс-платформенный формат для хранения текстовой информации. Сохраняет данные форматирования, позволяет производить вставку дополнительных объектов: формул, таблиц, сносок и др.

DOC - Имеют возможности сохранения форматирования, стилевого оформления, вложения картинок и других объектов в текст, а также поддержку гиперссылок.

DOCX - Усовершенствованный и лицензированный формат от Microsoft. Представляет собой следующий этап формата *.doc.

HTML - был разработан специально для создания веб-страниц, но благодаря своей универсальности, удобству и небольшому размеру стал широко использоваться для хранения текстовых данных.

PDF - Этот формат стал стандартом для обмена документами.

ODT - Поддерживает большую часть форматирования что и «DOCX», включая вставку изображений, таблиц и гиперссылок.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано n случайных чисел в диапазоне от -3 до 3. вычислите, сколько из них не с 0. составить программу, используя цикл for. для случайных ч исел используйте функцию random. n определяет пользователь. числа вывести на экран.
Ваше имя (никнейм)*
Email*
Комментарий*