archala
?>

Напишите программу для решения следующей . на контрольной работе по ученикам 9 класса было предложено 10 примеров. неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. сколько неудовлетворительных оценок было получено учениками? если хотя бы один из учеников правильно решил все , выведите yes, иначе выведите no. программа получает на вход количество учеников в классе n (1 ≤ n ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров. (pascal) входные данные 4 3 9 2 8 выходные данные 2 no

Информатика

Ответы

supercom-ru-marinaguseva4267
Var n,a,i,k:integer;
s:string;
begin
  s:='No'; k:=0;
  readln(n);
  for i:=1 to n do begin
    readln(a);
    if a<5 then k:=k+1;
    if a=10 then s:='Yes';
  end;
  writeln(k);
  writeln(s);
end.
Andrei Morozov
о том лылвдаоврч. малая лздп т в том числе и в итоге я не знаю что делать будешь сегодня в школе не было бы круто если бы я была на концерте была бы не сказала бы сразу и не надо от него и так все плохо было не до конца жизни был назначен на должность начальника штаба дивизии и в итоге я не знаю почему так долго не могла бы и г в состав округа уже не будет на месте и не знаю как г г г И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого. И далёкий путь начинается с близкого.
Ludmila777020
Все задачи однотипные, нужно знать понятия глубины цвета и как расчитывается объём для растрового изображения.
1.всего пикселей 128*128= 2^14(2 в 14-ой степени)
так как 32 цвет, то  один символ кодируется 5 битами (log2(32), если бы было 33 цвета то уже бы потребовалось 6 бит, так как 5 бы не хватило).
Нам нужно в килобайтах значит нужно разделить на 2^13 (т.к. в 1 кбайте 2^13 бит)

(2^14*5)/2^13=10 кбайт

2) (64*128*7)/2^13=(2^13*7)/2^13=7 кбайт
3)(64*256*8)/2^13= 2^17/2^13=2^4=16 кбайт
4)(32*1024*7)/2^13=(2^15*7)/2^13=4*7=28 кбайт
5)(1024*512*6)/2^13=(2^19*6)/2^13=64*6=384 кбайт
6)(512*256*5)/2^13=(2^17*5)/2^13=16*5=80 кбайт
7)(512*128*4)/2^13=2^18/2^13=2^5=32 кбайт
8)(256*128*3)/2^13=(2^15*3)/2^13=4*3=12 кбайт
9)(128*128*8)/2^13=2^17/2^13=2^4=16 кбайт
10)(24*2^13)/(128*256)=2^16*6/2^15=2*3=6 бит, значит 64 цвета
11)(10*2^13)/(128*128)=2^14*5/2^14=5 бит, значит 32 цвета
12)(7*2^13)/(64*128)=(7*2^13)/2^13=7 бит, значит 128 цветов
13)(16*2^13)/(64*256)=2^17/2^14=2^3=8 бит, значит 256 цветов
14)(28*2^13)/(32*1024)=7*2^15/2^15=7 бит, значит 128 цветов
15)(384*2^13)/(1024*512)=(3*2^20)/2^19=3*2=6 бит, значит 64 цвета
16)(80*2^13)/(512*256)=(5*2^17)/2^17=5 бит, значит 32 цвета
17)(32*2^13)/(512*128)=2^18/2^16=2^2=4 бита, значит 16 цветов
18)(12*2^13)/(256*128)=(3*2^15)/2^15=3 бита, значит 9 цветов
19)(16*2^13)/(128*128)=2^17/2^14=2^3=8 бит, значит 256 цветов (Каждый раз возводим в квадрат кол-во бит)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу для решения следующей . на контрольной работе по ученикам 9 класса было предложено 10 примеров. неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. сколько неудовлетворительных оценок было получено учениками? если хотя бы один из учеников правильно решил все , выведите yes, иначе выведите no. программа получает на вход количество учеников в классе n (1 ≤ n ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров. (pascal) входные данные 4 3 9 2 8 выходные данные 2 no
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

klepa-79
asparinapti39
aniramix
koldunovan
Galina
office
Irina_Nevretdinova1630
Андреевна
Dodkhobekovich1683
Андрей
shumeikoElena362
maestro6838
Анна1417
Vuka91
agitahell149