Lianchikavon
?>

Склавиатуру набраны случайным образом 3 числа. составить программу вычисления максимального из набранных чисел.

Информатика

Ответы

vera2job7
Program abc
var: x,y,c integer
begin
clrscr
writeln( "введите 3 числа")
readln (a,b,c)
if a>b and b>c then
writeln(a "большее")
else
if awriteln ( b "большее")
else
writeln (c "большее")
readkey
end.
может забыл что то,давно не писал на паскале
dpodstrel85
Var m : array[0..6] of Integer;
  i,k,N : Integer;
Begin
  For i:=0 to 6 do m[i]:=0;
  Readln(N);
  k:=6;
  While N>0 do
  Begin
    If N>=Power(2,k) then
    Begin
      N:=N-Trunc(Power(2,k));
      Inc(m[k]);
    end else Dec(k);
  end;
  For i:=0 to 6 do Writeln(Power(2,i),'  ',m[i],' шт.');
end.

Еще вариант:
Const
  NN = 7;
  money : array[1..7] of Integer = (1,2,4,8,16,32,64);
Var m : array[1..NN] of Integer;
  i,k,N : Integer;
Begin
  For i:=1 to NN do m[i]:=0;
  Readln(N);
  k:=NN;
  While N>0 do
  Begin
    If N>=money[k] then
    Begin
      N:=N-money[k];
      Inc(m[k]);
    end else Dec(k);
  end;
  For i:=1 to NN do Writeln(money[i],'  ',m[i],' шт.');
end.
lion13
Vara,b,c,d,x1,x2: real;
begin
writeln('Дано уравнение вида ax^2+bx+c=0');
Writeln ('Укажи переменную "a"');
readln(a);
Writeln ('Укажи переменную "b"');
readln(b);
Writeln ('Укажи переменную "c"');
readln(c);
if a = 0
 then writeln('Не квадратное уравнение!')
 else begin
      d:= sqr(b)-4*a*c;
      if d < 0 then writeln('Нет корней')
               else begin
                    x1:= (-b+sqrt(d))/2*a;
                    x2:= (-b-sqrt(d))/2*a;
                    writeln ('X1 =',x1,'  X2 =',x2);
                    end;
      end;
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Склавиатуру набраны случайным образом 3 числа. составить программу вычисления максимального из набранных чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Mariya dmitrievna
mnkrasnova
Antonov-Elena
tyrenumberone
DudukinSerega2507834
Ivan1568
rusmoney92
femida69
rmitin
melissa-80
Bella
appbiznessm
zoomagazinkotmatroskin
dmitzu8594
druzjkinaas22
▲