sawa-msk
?>

Нужно: 1) cоставить программу поиска максимума двух чисел 2) составить программу поиска минимума двух чисел

Информатика

Ответы

Евгений
Var a,b: real;
begin
  write ('Введите 2 числа');
  readln(a,b);
  if a<b then writeln (a,'<',b) //минимальное
  else if a>b then writeln (a,'>',b) // максимальное
    else writeln (a,'=',b) ; // числа равны
end.
sapelnikovk-74
Заметим, что числа образуют арифметическую прогрессию, а её сумма известна:
S= \frac{a_1+a_n}{2}\times n= \frac{1+n}{2}\times n
Поэтому два варианта программы: один вычисляет сумму накоплением, второй сразу определяет результат по формуле. Хороший пример того, что программист должен знать математику.

var
  n, i, s: integer;

begin
  Write('Введите натуральное число: ');
  Readln(n);
  if (n mod 2) = 0 then
  begin
    s := 0;
    for i := 1 to n do s := s + i;
    Writeln('Сумма чисел от 1 до ', n, ' равна ', s)
  end
  else Writeln('Введено нечетное число')
end.

Тестовое решение:

Введите натуральное число: 8
Сумма чисел от 1 до 8 равна 36

var
  n, s: integer;

begin
  Write('Введите натуральное число: ');
  Readln(n);
  if (n mod 2) = 0 then
    Writeln('Сумма чисел от 1 до ', n, ' равна ', ((1 + n) * n) div 2)
  else Writeln('Введено нечетное число')
end.

Тестовое решение:

Введите натуральное число: 8
Сумма чисел от 1 до 8 равна 36
dmitriy
Во втором прямоугольнике нужно написать "подойди к платью" и обвести эту рамку зеленым карандашом.
Нужно нарисовать стрелки вниз.
От треугольника в котором написано "остались платья?" нужно провести стрелку со словом "ДА" до второй черной стрелки(после фразы "выйди из шкатулки).Рамку "остались платья?" тоже надо обвести зелёным цветом.
Перед словом "конец" есть пустая рамка,там напиши "иди в шкатулку",а у стрелки которая ведёт к этой рамке нужно написать "НЕТ"
И последнее.От треугольной рамки с вопросом "все банты пришиты?" идёт стрелка вниз,рядом с ней напиши слово "ДА".И нужно самому провести стрелку до стрелки вниз от фразы "подойди к платью" и у новой стрелки написать слово "НЕТ"
Мы делали это в классе,в году поэтому должно быть правильно:)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Нужно: 1) cоставить программу поиска максимума двух чисел 2) составить программу поиска минимума двух чисел
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mgrunova3966
Staroverovanatasa494
Vladimirovich-Aleksandrovna96
Сергеевна-Пузанов
dentinnsmr467
osnickyi
atlantika7
Ivanskvortsov25
gorbelena1971
olgamalochinska
stepanova-natalie
agaltsova86
tgeraskina
Goldaram84
nataliaprintroll