danaya3005
?>

Последовательность состоит из натуральных чисел и завершается числом 0. определите, сколько элементов этой последовательности равны ее наибольшему элементу. решите на питоне 3 и без массивов можно с любыми циклами много и всем кто ответит скажу

Информатика

Ответы

timeev3160
a = int(input())
Max = a
n = 0
while a != 0:
    if a > Max:
        Max = a
        n = 1
    elif a == Max:
        n += 1
    a = int(input())
print(n, ' - ', Max)
eshabunina

ответ:Отла́дка — этап разработки компьютерной программы, на котором обнаруживают, локализуют и устраняют ошибки. Чтобы понять, где возникла ошибка, приходится:

узнавать текущие значения переменных;

выяснять, по какому пути выполнялась программа.

Запись в журнале компьютера из Марк II, с мотыльком, приклеенным к странице

Существуют две взаимодополняющие технологии отладки.

Использование отладчиков — программ, которые включают в себя пользовательский интерфейс для пошагового выполнения программы: оператор за оператором, функция за функцией, с остановками на некоторых строках исходного кода или при достижении определённого условия.

Вывод текущего состояния программы с расположенных в критических точках программы операторов вывода — на экран, принтер, громкоговоритель или в файл. Вывод отладочных сведений в файл называется журналированием.

Объяснение:

SVETLANAluiza1534

ответ:в правильный

Объяснение:

Исполнители бывают двух типов: формальные (выполняют действия не понимая смысла работы) и неформальные (понимают то, что делают и могут изменить действия в алгоритме)

а) симфонический оркестр - неформальный исполнитель - могут вносить свои чуства в исполнение, понимают то, что делают музыканты.

б) ученик сам решает - неформальный испонитель

в) ученик списывает - формальный исполнитель

г) фармацевт - формальный (точное исполнение рецепта иначе может быть другой результат от лечения)

д) врач - неформальный исполнитель, тк зная возможные причины рассматривает разыне варианты, учитывая особенности данного человека

е) автомат - формальный исполнитель, вообще не понимает своих действий, выполняет заданную программу

ж) компьютер - формальный исполнитель - выполняет программу, созданную программистами.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Последовательность состоит из натуральных чисел и завершается числом 0. определите, сколько элементов этой последовательности равны ее наибольшему элементу. решите на питоне 3 и без массивов можно с любыми циклами много и всем кто ответит скажу
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Moroshkina-Aristova2011
cutur3414
legezin
pizniak
annazhurawlewa
adminaa
balabina-Olesya
maslprod
Жуков219
club-pushkin
korj8
kalina1372
kate281078
ooofishai4064
apromovich1