saryba
?>

Составить программу вычисляющую сумму квадратов первых n натуральных чисел. количество чисел n задаётся во время работы программы. для разработки использовать приложение visual basic.

Информатика

Ответы

asi19776
1. Консольное приложение:

Module Module1

    Sub Main()
        Dim n, i, s As Integer
        Console.Write("Введите число N")
        n = Console.ReadLine
        s = 0
        For i = 1 To n
            s = s + i * i
        Next
        Console.Write(s)
        n = Val(Console.ReadLine)

    End Sub

End Module

2. Приложение Windows Forms:
На форме 3 объекта:
TextBox1 - для ввода N
Textbox2 - для вывода суммы квадратов
Button1 - чтобы запустить процесс вычислений

Public Class Form1

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim i, s As Integer
        s = 0
        For i = 1 To Val(TextBox1.Text)
            s = s + i * i
        Next
        TextBox2.Text = s
    End Sub
End Class
potapenkoon72
// PascalABC.NET 3.0, сборка 1160 от 05.02.2016
function SHarm(m:integer):real:=Range(1,m).Select(x->1/x).Sum;

begin
  var a:=ReadReal('a=');
  var m:=1;
  while SHarm(m)<=a do Inc(m);
  Writeln('m=',m)
end.

Тестовое решение:
a= 5
m=83

Указанный ряд - это известный в математике расходящийся гармонический ряд. Его приближенное значение суммы можно определить по формуле Эйлера:
\displaystyle S(m)=\sum_{i=1}^m \frac{1}{i} \approx \ln(m)+C, \quad C\approx 0.577\ 215\ 664\ 902
Нам требуется определить m, для которого S(m)>a, тогда
\displayvalue \ln(m)+C\ \textgreater \ a; \ ln(m)\ \textgreater \ a-C \to m\ \textgreater \ e^{a-C}
Будем искать m, отбрасывая дробную часть полученного результата, а потом делать уточнение путем непосредственного вычисления сумм.

// PascalABC.NET 3.0, сборка 1160 от 05.02.2016

const C=0.577215664902; // Постоянная Эйлера-Маскерони

function SHarm(m:integer):real:=Range(1,m).Select(x->1/x).Sum;

begin
  var a:=ReadReal('a=');
  var m:=1;
  if a<=3 then begin
    while SHarm(m)<=a do Inc(m);
    Writeln('m=',m)
    end
  else begin
    var s:real:=Int(exp(a-C));
    if a<10 then begin
      m:=Trunc(s);
      while SHarm(m)<=a do Inc(m);
      Writeln('m=',m)
      end
    else Writeln('m=',s)
    end
end.

В этом случае можно проводить оценочный расчет для больших значений а:

a= 200
m=4.05709150011779E+86
melissa-80
Программа векторной графики CorelDRAW 12 вместе с программой растровой графики Corel PHOTO-PAINT 12 и несколькими дополнительными программами составляет пакет графических программ CorelDRAW Graphic Suite 12, разработанный известной фирмой-производителем графических программных продуктов Corel Corporation. CorelDRAW 12 предназначена для разработки макетов документов, в которых преобладает графическая информация, с целью их публикации в качестве типографской продукции и в электронном виде. 
Программы, позволяющие обрабатывать векторные объекты наряду с растровыми изображениями и текстовой информацией, обычно называются программами векторной графики. Это название можно отнести и к программе CorelDRAW 12. Вместе с тем, ее функциональные возможности существенно шире, чем у других известных программ подобного типа (Macromedia FreeHand и Adobe Illustrator). 
надеюсь это подойдёт. когда то писала такое 5 получила

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисляющую сумму квадратов первых n натуральных чисел. количество чисел n задаётся во время работы программы. для разработки использовать приложение visual basic.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

studiojanara
osirparts7854
marinarodina90
mitin228133770
игнатова_Сергей1228
Kharkina1328
inainainainaina0073
tushina2020
tochkamail7
sharovaeln6
Ulianev77
ludakamasana
Irinalobanowa
far-yuliya128
kv135549