Зинина-Олесия
?>

Составте программу решающую следующую дано число н если оно неотрицательно то возвести его в квадрат а если отрицательно то в третью степень

Информатика

Ответы

tatk00
Program pr;
uses crt;
var n, r : integer;
begin
clrscr;
writeln('Enter n:');
readln(n);
if n>0 then
begin
r:=n*n;
end
else
begin
r:=n*n*n;
end;
writeln('Result=',r);
readln;
end.
asvavdeeva

использовать Чертежник

алг

нач

цел в, г

вывод "Введите количество повторов по вертикали: "

ввод в

вывод "Введите количество повторов по горизонтали: "

ввод г

нц в раз

нц г раз

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (1,0)

сместиться на вектор (0,-1)

сместиться на вектор (-1,0)

поднять перо

сместиться на вектор (-1,0)

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (1,1)

сместиться на вектор (1,0)

сместиться на вектор (1,-1)

сместиться на вектор (0,-1)

сместиться на вектор (-1,-1)

сместиться на вектор (-1,0)

сместиться на вектор (-1,1)

поднять перо

сместиться на вектор (-1,0)

опустить перо

сместиться на вектор (0,1)

сместиться на вектор (2,2)

сместиться на вектор (1,0)

сместиться на вектор (2,-2)

сместиться на вектор (0,-1)

сместиться на вектор (-2,-2)

сместиться на вектор (-1,0)

сместиться на вектор (-2,2)

поднять перо

сместиться на вектор (5,0)

кц

сместиться на вектор (-(г*3),-3)

кц

кон

Объяснение:

картинка


3. Составьте программу рисования узора, показанного на рисунке. Количество повторений элементов узор
morsh9345
ответ: 1111011111001011
Переводим в десятичную: 
F7CB16 = 15∙163+7∙162+12∙161+11∙160 = 61440+1792+192+11 = 6343510 
Потом это число переводим в двоичную:
63435/2=31717 (остаток 1)
31717/2=15858 (остаток 1)
15858/2=7929 (остаток 0)
7929/2=3964 (остаток 1)
3964/2=1982 (остаток 0 )
1982/2=991 (остаток 0)
991/2=495 (остаток 1)
495/2=247 (остаток 1)
247/2=123 (остаток 1)
123/2=61 (остаток 1)
61/2=30 (остаток 1)
30/2=15 (остаток 0)
15/2=7 (остаток 1)
7/2=3 (остаток 1)
3/2=1 (остаток 1)
Последний ответ 3/2=1 - эту единицу берём и наоборот собираем остатки.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составте программу решающую следующую дано число н если оно неотрицательно то возвести его в квадрат а если отрицательно то в третью степень
Ваше имя (никнейм)*
Email*
Комментарий*