ba5-m
?>

Составить программу, которая запрашивает два числа и находит третье по формуле с=(а2+в2)-5*а*в. вывести третье число на экран

Информатика

Ответы

Chervonnaya-Aleksei
Var     s: integer;     i: integer; begin s: =0; for i: = 30 to 80 do       if i mod 10 = 4 then s: =s+i; writeln('s = ',s); end. var     s,n,i: integer; begin s: =0; n: =0; for i: = 10 to 70 do       if i mod 10 = 5 then             begin             s: =s+i;             n: =n+1;             end; writeln('sr = ',s/n); end.
murza2007

ответ

4,0/5

2

SilverWind

   середнячок

   8 ответов

   2.6 тыс. пользователей, получивших

1. вывести на экран 6 раз своё имя

program imya;

const n=6;

var i:integer;

begin

for i:=1 to n do

writeln('ваше имя');

end.

Пояснения: делала с цикла (можно было написать и шесть раз writeln, но так удобнее). Переменную n ввела для быстрого изменения значений (если нужно будет написать имя не 6, а, к примеру, 8 раз, нужно было заменить только вначале). Ещё хочу отметить, что имя вводится по-английски и нельзя терять апострофы ( ' ).

2. program sum;

var sum:integer;

m:array[1..4] of integer;

i:integer;

begin

m[1]:=6

for i:=2 to 4 do begin

m[i]:=m[i-1]+1;

end;

sum:=m[1];

for i:=2 to 4 do begin

sum:=sum+m[i];

end;

writeln(sum);

end.

Пояснения: можно было делать и по-другому, но так тоже верно. Тут использовалось два цикла и массив. А блок-схему сами сделайте)))

3. program n!;

var n:real;

c:integer;

m:array[1..n] of integer;

begin

readln(n)

m[1]:=1;

for i:=2 to n do begin

m[i]:=m[i-1]+1;

end;

c:=m[1]

for i:=1 to n do begin

c:=c*m[i];

end;

writeln('n!',c);

end.

Если что не понятно, пишите, объясню

Объяснение:

сосиска

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая запрашивает два числа и находит третье по формуле с=(а2+в2)-5*а*в. вывести третье число на экран
Ваше имя (никнейм)*
Email*
Комментарий*