Ну функция randomize() создаёт, перемешивает новые рандомные числа, а random() их предоставляет. Разных вариаций написания много, я например сделал с массивом, можно в принципе и без него, но с ним лучше т.к. числа хранятся в массиве и их можно выводить в будущем, если это слишком сложно для тебя, то я могу написать программу без использования массива.
Var i,b:integer; A:array[1..20] of integer; Begin Randomize(); for i:=1 to 20 do A[i]:=Random(0,50); Write('Из чисел: '); for i:=1 to 20 do begin if i=20 then Writeln(A[i]) else Write(A[i],', ') end; Write('Кол-во четных равняется: '); for i:=1 to 20 do if (A[i] mod 2 = 0) then b:=b+1; Writeln(b) End.
Файл с кодом прикреплю во вложения, спрашивай если не понятна какая-то функция, объясню, дабы ты не стоял в ступоре перед учительницей...
firsova5911
11.07.2020
1) 1,5 Кбайта=1,5 * 1024 байта = 1,5 * 1024 *8 бит = 12288 бит 12288/3072 = 4 бита - на один символЗначит N=2^4 = 16 символов в алфавите.
2) 1 символ = 8 бит = 1 байт
150*40*60=360000 (символов/байт) это ответ и есть, но можно для удобства перевести в килобайты 1 килобайт = 1024 байт
360000/1024=351,5625
ответ: 360000 байт или 351,5625 килобайт
3) посмотрим сколько же всего символом на двух страницах:256*2 = 512 сиволов.Теперь посмотрим сколько байт они занимают:1 килобайт (по старым нормам) = 1024 байта (по новым уже нет :( )1024/16 = 64 байта. в одном байте 8 бит, значит 64 байта это 64*8 = 512 бит информации.разделим: 512/512 = 1 бит информации на символ. Мощность алфавита = 2 в степени количества информации на символ, то есть 2 в первой, или просто 2.ответ: мощность алфавита равна двум.
Разных вариаций написания много, я например сделал с массивом, можно в принципе и без него, но с ним лучше т.к. числа хранятся в массиве и их можно выводить в будущем, если это слишком сложно для тебя, то я могу написать программу без использования массива.
Var i,b:integer;
A:array[1..20] of integer;
Begin
Randomize();
for i:=1 to 20 do
A[i]:=Random(0,50);
Write('Из чисел: ');
for i:=1 to 20 do
begin
if i=20 then
Writeln(A[i])
else Write(A[i],', ')
end;
Write('Кол-во четных равняется: ');
for i:=1 to 20 do
if (A[i] mod 2 = 0) then b:=b+1;
Writeln(b)
End.
Вот выводы программы, которые у меня получились.
Первый раз:
Из чисел: 42, 1, 46, 24, 36, 9, 22, 16, 7, 41, 49, 46, 27, 29, 50, 44, 44, 10, 48, 36
Кол-во четных равняется: 13
Второй раз:
Из чисел: 5, 16, 16, 27, 1, 48, 46, 45, 46, 13, 21, 18, 24, 45, 14, 13, 33, 14, 21, 30
Кол-во четных равняется: 10
Третий раз:
Из чисел: 15, 2, 24, 42, 49, 43, 5, 48, 8, 1, 45, 9, 20, 24, 35, 19, 11, 15, 26, 33
Кол-во четных равняется: 8
Файл с кодом прикреплю во вложения, спрашивай если не понятна какая-то функция, объясню, дабы ты не стоял в ступоре перед учительницей...