x=int(input('Введите число: '))
if x>0:
print('Число положительное')
else:
print('Число не положительное')
Объяснение:
Во второй строке стоит неправильный оператор сравнения (x<0), если это условие истинно, то число отрицательное, а надо определить является ли число положительным
Во второй строке пропущено двоеточие (:) после условия
В третьей строке отсутствует отступ перед print
В четвертой строке пропущено двоеточие (:) после else
В пятой строке отсутствует отступ
В пятой строке отсутствует оператор print, со скобками и кавычками для строки вывода
В пятой строке неправильная формулировка строки вывода (Число отрицательное), т.к. при такой формулировке 0 становится отрицательным числом, что будет ошибкой
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу на языке паскаль. скорость лодки в стоячей воде vл км/ч, скорость течения реки vр км/ч (vр < vл время движения лодки по озеру т1 ч, а по реке (против течения) — т2 ч. определить путь s, пройденный лодкой. добавлю 10, если будет без ошибок.
begin
v1:=0;
v2:=0;
while (v2>=v1) do begin
writeln('введите скорость лодки');
readln(v1);
writeln('введите скорость течения реки');
readln(v2);
if (v2>=v1) then writeln('введены неправильные данные');
end;
writeln('введите время движения лодки по озеру');
readln(t1);
writeln('введите время движения лодки по реке против течения');
readln(t2);
s1:=v1*t1;
s2:=(v1-v2)*t2;
so:=s1+s2;
writeln('длина общего пути ',so);
end.