ambiente-deco516
?>

Mas = for i in range(1, 5): mas[i] +=mas[i-1]*3 в ответе укажите через пробел, чему изначально были равны элементы массива mas, если в результате работы программы они оказались равны 3 14 47 142 428 (в порядке возрастания индексов

Информатика

Ответы

okasnab
Изначально массив был следующим:
3 5 5 1 2

Тест для проверки:
MAS = [3,5,5,1,2]
print(MAS[0],sep=' ', end=' ')
for i in range(1,5):
    MAS[i] +=MAS[i-1]*3
    print(MAS[i],sep=' ', end=' ')

Результат:
3 14 47 142 428
nikdenly

1) для перевода из 10-й в двоичную 2-ую систему счисления нужно число в десятичной системе разделить на 2 и записать остаток , затем тоже самое сделать с целой часть и повторять пока не останется только 1 или 0. конечное числом будут остатки записанные в обратном порядке.

1450/ 2 = 725 остаток 0

725 / 2 = 362 остаток 1

362 / 2 = 181 остаток 0

181 / 2 = 90 остаток 1

90 / 2 = 45 остаток 0

45/ 2 = 22 остаток1

22/2 = 11 остаток 0

11/ 2 = 5 остаток 1

5 / 2 = 2 остаток 1

2 / 2 = 1 остаток 0

1 / 2 = 0 остаток 1

 

результат: 10110101010

 

в 2-х байтовой ячеке всего 16 разрядов, а в наше числе 11 , значит спереди нужно дописать 5 нулей и получим нужное представление

0000010110101010

 

2)

для перевода в 16 систему нужно сначало перевести в 2-ю систему счисления, потом записать обратный код, почитать дополнительный и тогда перевести в 16-ю

вот 1450 в 2-й системе

0000010110101010

обратный код это код в котором все 0 заменены на 1, а 1 на 0

1111101001010101

чтобы получит дополнительный код нужно прибавить 1

1111101001010110

теперь смотрим по 4 разряда и заменяем 1 символом в 16 системе счисления

1111 = f

1010 = a

0101 = 5

0110 = 6

искомое число fa56

3)

  для перевода из 16 в 2 систему счисления нужно каждую цифру числа умножит на 16 в степень равным номеру цифры(справа на лево, отсчет с 0)

f67d(в 16 системе счисления) = 15 * 16 ^3 + 6 * 16 ^2 + 7 * 16^1 + 13 * 16 ^0 = 61440 + 1536 + 112 + 13 = 63101(в 10 системе счисления)

Kubataeva Nikolaevich1389
Pascalabc.net var   a: array[1..10000] of integer;   kz,maxp,n,i,j: integer;   begin     i: =0;   maxp: =integer.minvalue;   writeln ('готов к приему чисел');   repeat     i: =i+1;     readln (a[i]);     until a[i]=0;   n: =i-1;   readln (kz);   for i: =1 to n-1 do      for j: =2 to n do        if maxp< (a[i]*a[j]) then maxp: =(a[i]*a[j]);     writeln ('получено ',n,' чисел');   writeln;   writeln ('полученное контрольное значение: ',kz);   writeln;   writeln ('вычисленное контрольное значение: ',maxp);   writeln;   if kz=maxp      then writeln ('контроль пройден')     else writeln ('контроль не пройден'); end. результаты: 1) готов к приему чисел 1 2 3 4 5 0 20 получено 5 чисел полученное контрольное значение: 20 вычисленное контрольное значение: 20 контроль пройден 2) готов к приему чисел 1 2 3 4 5 6 0 20 получено 6 чисел полученное контрольное значение: 20 вычисленное контрольное значение: 30 контроль не пройден

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Mas = for i in range(1, 5): mas[i] +=mas[i-1]*3 в ответе укажите через пробел, чему изначально были равны элементы массива mas, если в результате работы программы они оказались равны 3 14 47 142 428 (в порядке возрастания индексов
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

смирнов1127
magazintrofey
соловьев_Куркина
tarasovs
AntonovaAvi1716
Yurevna991
mira15963256
dmitrovlug8248
struev2003260
levickaalubov5
Игорь Андрей
satinvova
pnat1235
tol1974656
mmctriitsk