Igorevich1559
?>

20 ! составить программу на языке с++: 1. описать структуру с именем tovar, которая содержит следующие поля: - name - название товара; - cost_z - цена закупки товара; - cost_p - цена продукции. - quantity -количество единиц товара; - pributok - прибыль. 2. написать программу, которая использует данную структуру и выполняет следующие действия: - вводит из текстового файла sklad.dat список книг, согласно структуры, и выводит его на экран, используя элемент список; - вычисляет прибыль по каждому товару; - добавляет в начало списка n новых товаров; - удаляет товар, который приносит прибыль; - с вновь списка записать в двоичный файл sklad.sol все товары, которые имеют наибольшую прибыль. 3. написать программу, которая считывает из двоичного файла sklad_n.dat, данные обо всех товарах и записывает в файл tovar.dat товар, цена которого превышает среднюю цену товара .

Информатика

Ответы

kengyra
1)194: пример: 4199(сумма нечетных=19,сумма четных=4.в порядке убывания)"+" 2)1913(должна быть хотя бы одна цифра четная)"-" 3)1420(цифры не в порядке убывания.) "-" 4)1118: нам нужно получить четное число 18: a)пусть нечетные цифры = 9,9.но тогда у нас остались четные числа,но мы никак не сможем получить 11. b)чтобы получить 18 из четных чисел нужно,чтобы числа = 8,8,4(максимум),но тогда мы не сможем получить 11,т.к. максимальная цифра=9.значит "-" 5)1212 пример: 5766(сумма четных=12(6+6),сумма нечетных=12(5+7)) "+" 6)205 нам нужно получить 20: мы не сможем получить 20 из нечетных чисел,т.к. из нечетных чисел нам нужно получить 5. максимальные цифры из четных равны=8,8,4.(20). и одна цифра нечетная: 5.пример: 8548 "+" 7)420: пусть нам нужно получить 42,но мы не сможем получить данную сумму,т.к. максимум=36(9,9,9,9) "-" 8)294: пусть одна из цифра=4,т.е. остальные у нас нечетные.опять же максимальная сумма=27(9,9,9).значит "-" 9)55: должна быть хотя бы одна цифра четная."-" ответ: 3 числа
Lyalikova
Var n,i,k,k1: integer;     a: array[1..1000]of integer;   begin    k: =0;     k1: =1;     read(n); //сдесь вводится количество элементов в     for i: =1 to n do    begin      randomize;       a[i]: =random(31)-10;       end;     for i: =1 to n do      begin      k: =k+a[i];       k1: =k1*a[i];     end;     for i: =1 to n do    write(a[i],' ');     writeln(k); //сумма     writeln(k1); //произведение   end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

20 ! составить программу на языке с++: 1. описать структуру с именем tovar, которая содержит следующие поля: - name - название товара; - cost_z - цена закупки товара; - cost_p - цена продукции. - quantity -количество единиц товара; - pributok - прибыль. 2. написать программу, которая использует данную структуру и выполняет следующие действия: - вводит из текстового файла sklad.dat список книг, согласно структуры, и выводит его на экран, используя элемент список; - вычисляет прибыль по каждому товару; - добавляет в начало списка n новых товаров; - удаляет товар, который приносит прибыль; - с вновь списка записать в двоичный файл sklad.sol все товары, которые имеют наибольшую прибыль. 3. написать программу, которая считывает из двоичного файла sklad_n.dat, данные обо всех товарах и записывает в файл tovar.dat товар, цена которого превышает среднюю цену товара .
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kuchino09
самир1078
Yekaterina_Popova1413
koam20167459
yrgenson2011801
nadezhdasvirina
dashafox8739
serge-lysoff
Анатольевич-Митюшин
ev89036973460
antonkovalev89
dimari81
Avdeeva Inga1505
Ye.Vadim
frdf57
▲