Pirogovskii695
?>

Написать программу, которая принимает от пользователя количество числовых значений (указывает сам пользователь) для переменной и считает количество введенных трехзначных чисел, если учитывать, что вводиться могут числа в диапазоне от 0 до 10000 (по умолчанию

Информатика

Ответы

fursov-da
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
var a,i,n,n3:integer;
begin
    writeln('Введите количество чисел');readln(n);
    for i:=1 to n do begin
      readln(a);
      if (a>99) and (a<1000) then n3:=n3+1;
    end;
    writeln('Всего трехзначных чисел :',n3);
end.

Тестовое решение:
Введите количество чисел
5
22
123
4
435
12
Всего трехзначных чисел :2
Никитина580
Program example;
Uses CRT;
VAR x: integer;
VAR y: integer;
VAR c: integer;
begin;
Writeln('Уравнение для решения это c=x+y');
Writeln('Введите значение x...');
Readln(x);
Writeln('Введите значение y...');
Readln(y);c:=x+y;
Writeln('Результат, c=', c);
readln;
ClrScr;
Writeln('Уравнение для решения это c=x-y');
Writeln('Введите значение x...');
Readln(x);
Writeln('Введите значение y...');
Readln(y);
c:=x-y;
Writeln('Результат, c=', c);
readln;
ClrScr;
Writeln('Уравнение для решения это c=x*y');
Writeln('Введите значение x...');
Readln(x);
Writeln('Введите значение y...');
Readln(y);
c:=x*y;
Writeln('Результат, c=', c);
readln;
end.

Вот в принципе 3 уравнения на вычисления, комбинации (переменные) вписываешь сам. Название придумай. Я вопрос не очень понял, поэтому если что не так, все-равно навсякий случай сохрани ;)
fucksyara
На языке поисковых запросов Янд-екса
(думаю, в Гуг-ле тоже самое) знаки имеют такие значения:
a | b - сайты, на которых есть любое слово a или b или оба
Сталлоне | Уиллис - найдет все страницы со Сталлоне и все с Уиллисом.
1 200 000 сайтов
a & b - сайты, на которых слова а и b есть в одном предложении.
Уиллис  & Шварценеггер - оба в одном предложении, 94 100 сайтов.
Сталлоне & Шварценеггер - тоже оба в одном, 105 900 сайтов.
Запрос (Сталлоне | Уиллис) & Шварценеггер выдаст:
1) Сайты Сталлоне & Шварценеггер - 105 900
2) Сайты Уиллис  & Шварценеггер - 94 100
Всего 105 900 + 94 100 = 200 000 сайтов.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая принимает от пользователя количество числовых значений (указывает сам пользователь) для переменной и считает количество введенных трехзначных чисел, если учитывать, что вводиться могут числа в диапазоне от 0 до 10000 (по умолчанию
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ЮлияНиколаевна1748
juli19657
olimov
Vasilii1891
mulyugina365
Вагифович
Александр
Maksimova1320
kolyabelousow4059
lobanosky162
zimin0082
Хачатурович978
ninazholnerova9
КалюкМарасанов1026
Natacha3636672