evg-martenyuk
?>

С++ напишите программу, которая заполняет матрицу неотрицательными числами по диагоналям (см. пример значение элемента матрицы равно расстоянию от левого верхнего угла матрицы. входные данные во входной строке записаны через пробел размеры матрицы: количество строк n и количество столбцов m ( 1 ≤ n , m ≤ 100 ). выходные данные программа должна вывести полученную матрицу по строкам. примеры входные данные 4 5 выходные данные 0 1 2 3 4 1 2 3 4 5 2 3 4 5 6 3 4 5 6 7

Информатика

Ответы

Дмитриевич Бирковская69
Вот сам код в комментарии, также прикрепил в виде файла:
aeykin

1) program exec;

var a:array[1..20] of integer;

var p,i:integer;

begin

randomize;

for i:=1 to 20 do begin

a[i]:=random(50);

writeln (a[i]);

if (a[i] mod 2<>0) then p:=p+1;

end;

if (p>0) then writeln ('Присутствуют нечётные элементы')

else writeln ('Не присутствуют нечётные элементы');

end.

2) program exec;

var a:array[1..20] of integer;

var p,i:integer;

begin

randomize;

for i:=1 to 20 do begin

a[i]:=random(50);

writeln (a[i]);

if (a[i] mod 2=0) then a[i]:=a[i]+1

else a[i]:=a[i]*2;

end;

writeln ('---'); // разделение двух массивов

for i:=1 to 20 do writeln (a[i]);

end.

Matveevanastya0170

Обозначим людей 1,2,5,10 по времени, затрачиваемому на переход через мост.

Вот последовательность переходов, гарантирующая минимальное время (время на каждый переход указано в скобках):

0. Все на исходной позиции: 1, 2, 5, 10 ⇔ — (0 мин.)

1. 1 и 2 идут на другой берег: 5, 10 ⇔ 1, 2 (2 мин.)

2. 1 возвращается: 1, 5, 10 ⇔ 2 (1 мин.)

3. 5 и 10 идут на другой берег: 1 ⇔ 2, 5, 10 (10 мин.)

4. 2 возвращается: 1, 2 ⇔ 5, 10 (2 мин.)

5. 1 и 2 идут на другой берег: — ⇔ 1, 2, 5, 10 (2 мин.)

Итого: 2 + 1 + 10 + 2 + 2 = 17 минут.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

С++ напишите программу, которая заполняет матрицу неотрицательными числами по диагоналям (см. пример значение элемента матрицы равно расстоянию от левого верхнего угла матрицы. входные данные во входной строке записаны через пробел размеры матрицы: количество строк n и количество столбцов m ( 1 ≤ n , m ≤ 100 ). выходные данные программа должна вывести полученную матрицу по строкам. примеры входные данные 4 5 выходные данные 0 1 2 3 4 1 2 3 4 5 2 3 4 5 6 3 4 5 6 7
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

bar02
Кузнецов
Александра Викторович531
100 нарисовать замок в паскаль абс ​
Irinagarmonshikova
ksv89
.Е.-Прокопьева
Kochinev4
vikapar2646
Georgievich-Zamudinovna2003
mmreznichenko
манукян29
antoha512
Елизавета Александр2011
rimmaskis
SAMSCHOOL96
▲