sky-elena712558
?>

Написать программу на паскале: ученики моего класса получили оценки на экзамене по .найти: 1.средний класса 2.минимальную отметку 3.самую лучшую отметку 4.и количество не здавших экзамен

Информатика

Ответы

Елизавета Александр2011
Для десяти студентов, ответ в картинке. 
Написать программу на паскале: ученики моего класса получили оценки на экзамене по .найти: 1.средний
Tatianarogozina1306
А еще можно без головной боли

// PascalABC.NET 3.0, сборка 1111
var
  a,b:BigInteger;
  sa,sb:string;
begin
  Write('Первое слагаемое: '); Readln(sa);
  if BigInteger.TryParse(sa,a)=False then Writeln('Это не целое число!')
  else begin
    Write('Второе слагаемое: '); Readln(sb);
    if BigInteger.TryParse(sb,b)=False then Writeln('Это не целое число!')
    else Writeln('Точный результат: ',a+b)
    end
end.

Тестовое решение:
Первое слагаемое: 5423323409523846095938445870434764308454095
Второе слагаемое: 7425543205430235436743455446541423534233
Точный результат: 5430748952729276331375189325881305731988328
Semenova
Var
  s,s1:string;
  a,b:array[1..100]of integer;
  i,n,x,k:integer;
    begin
      readln(s);
      readln(s1);
      n:=1;
       if length(s)>length(s1) then
        x:=length(s)
        else x:=length(s1);
         for i:=1 to length(s) do
         begin
          val(copy(s,i,1),k,n);
          a[i+x-length(s)]:=k;
         end;
           for i:=1 to length(s1) do
         begin
          val(copy(s1,i,1),k,n);
          b[i+x-length(s1)]:=k;
         end;
      for i:=1 to length(s) do
        a[i]:=a[i]+b[i];
        for i:=length(s) downto 2 do
        begin
         a[i-1]:=a[i-1]+a[i]div 10;
         a[i]:=a[i]mod 10;
        end;
      for i:=1 to length(s) do
       write(a[i]);
        
        
      end.
         

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на паскале: ученики моего класса получили оценки на экзамене по .найти: 1.средний класса 2.минимальную отметку 3.самую лучшую отметку 4.и количество не здавших экзамен
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Yulechkaakulova1993
okovyrova1
megaromeo
ajuli2
lelikrom2202
Максим
a60ikurgannikova
mixtabak2
zotcet7
Koshovkina1721
elena-novikova-1992
Nastyakarysheva8750
hachatryanlilit1983
ktv665
spadikov