Хромов1501
?>

Напишите программу на языке pascal, которая с цикла for to считала s: =1-2+3-4+5-6+7-8+9-

Информатика

Ответы

rb-zakaz
Var n,i,s:integer;
begin
write('n = '); readln(n);
s:=0;
for i:=1 to n do 
 if i mod 2 =0 then s:=s-i else s:=s+i;
writeln('s = ',s);
end.

Пример:
n = 10
s = -5
ГармаеваЕкатерина1637
Var n,s,i:integer;
begin
  write('введите n ');
  readln(n);
  for i:=1 to n do if i mod 2 <> 0 then s:=s+i else s:=s-i;
  writeln('s = ',s);
end.
zaretskaya37
// 7
begin
    var arr := ArrRandom(13);
    arr :=  arr.OrderByDescending(x->x).ToArray;
    arr.Println;
    Print('Sum = ', arr.Where(x->x>10).Sum() + newline +
            'Count = ',arr.Where(x->x>10).Count);
end.

// 8
begin
   var arr := ArrRandom(10);
   Sort(arr);
   arr.Println;
   Print('Sum = ', arr.Where(x -> x mod 5 = 0).Sum() + newline +
           'Count = ', arr.Where(x -> x mod 5 = 0).Count);
end.

// 9
begin
   var arr := ArrRandom(15);
   arr := arr.OrderByDescending(x -> x).ToArray;
   arr.Println;
   Print('array elements squares sum is = ', arr.Sum(x -> x * x));
end.
ruslanchikagadzhanov
1. Для кодирования одного из 8 цветов требуется log(2)8 = 3 бита (2^3=8). Память, занимаемая одной фотографией:
512*256*3 бит = 512*256*3 / (8*1024) Кбайт = 48 Кбайт.
Две фотографии займут 2*48 = 96 Кбайт

2. Для кодирования одного из 1024 цветов требуется log(2)1024 = 10 бит (2^10=1024). Объем одного изображения = 256*32*10 бит = 256*32*10 / (8*1024) Кбайт = 10 Кбайт. Количество изображений, которые можно прикрепить = 100/10 = 10

3. Глубина цвета = log(2)512 = 9 бит (2^9=512)

4. Количество точек отсканированного изображения = 4*16*64*16.
128 Мбайт = 128*1024 Кбайт = 128*1024*1024 байт = 128*1024*1024*8 бит.
Глубина цвета = 128*1024*1024*8 / (4*16*64*16) = 16384 бит (как-то очень много).

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу на языке pascal, которая с цикла for to считала s: =1-2+3-4+5-6+7-8+9-
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

egoryandiana3727283
Александра Викторович531
eidevyatkina
Galinagol559
npprang21
yugraspets
appbiznessm
rayman777
dkedrin74038
Владислав-Аветисян217
Gor Anatolevich
Sergeevich-irina
shangina1997507
turoverova5
elenak26038778