volkovaekaterina303
?>

Вpascal №4. дана величина a, выражающая объем информации в мегабайтах. составьте программу перевода величины а в более мелкие единицы информации. №5. даны длины сторон треугольника a, b, c. найти площадь треугольника s. составьте программу решения поставленной . , где р – полупериметр №6. для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (c

Информатика

Ответы

Глазкова633
4.
var
a:real;
begin
write('Введите количество мегабайт=');read(a);
writeln('Количество килобайт=',a*1024);
writeln('Количество байт=',a*1024*1024);
writeln('Количество бит=',a*1024*1024*8);
end.

5.
var
a,b,c,p,S:real;
begin
write('Введите сторону a=');read(a);
write('Введите сторону b=');read(b);
write('Введите сторону c=');read(c);
P:=(a+b+c)/2;
S:=sqrt(p*(p-a)*(p-b)*(p-c));
write('S=',s:5:2);
end.

6.
var
a:integer;
begin
write('Введите количество суток=');read(a);
writeln(24*a,' ','часов');
writeln(60*24*a,' ','минут');
writeln(60*60*24*a,' ','секунд');
end.
mv7095
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var n:=ReadInteger('n=');
  if n<0 then Writeln(n,'! не определено: n<0')
  else
    if n=0 then Writeln('0!=1')
    else begin
      var p:BigInteger:=1;
      for var i:=2 to n do p*=i;
      Writeln(n,'!=',p)
      end
end.

Тестовое решение:
n= 138
138!=691778647261948849222819828311491035886734385827028118707676848307166514238979223884785249055995983385450621636277440066920043595627074569065446040152660143904127838730788278294186615891819670506731208704000000000000000000000000000000000
volna22051964
// PascalABC.NET 3.0, сборка 1157 от 02.02.2016
begin
  var a:array[1..20] of integer;
  Randomize;
  for var i:=1 to 20 do a[i]:=Random(-50,50); a.Println;
  var b:=Range(2,20,2).Select(i->a[i]);
  Writeln('Элементы с четными индексами по возрастанию');
  b.Sorted.Println;
  Writeln('Элементы с четными индексами по убыванию');
  b.SortedDescending.Println;
end.

Тестовое решение:
-15 46 -34 -3 43 16 -17 -28 -19 12 -28 -11 48 -12 -1 33 -37 9 6 -40
Элементы с четными индексами по возрастанию
-40 -28 -12 -11 -3 9 12 16 33 46
Элементы с четными индексами по убыванию
46 33 16 12 9 -3 -11 -12 -28 -40

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Вpascal №4. дана величина a, выражающая объем информации в мегабайтах. составьте программу перевода величины а в более мелкие единицы информации. №5. даны длины сторон треугольника a, b, c. найти площадь треугольника s. составьте программу решения поставленной . , где р – полупериметр №6. для заданного количества суток (tfh) требуется определить количество часов (h), минут (m) и секунд (c
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alex091177443
Voronin-Albertovich
Oksana-Kirakosyan1301
kisuhakisa
germanleon
anovikovsr
mbykovskiy
gelena03
Stepanovich_Makarov
Андрееевич787
annakuznetsova841
verkop9
Leonidovich_Elena771
Natalya1895
alexseyzyablov