ninakucherowa
?>

Составить программу которая заполняет массив значением квадратов индексов элементов

Информатика

Ответы

Dmitrievna405
Int massive = int[10];
for(int i = 0; i < 10; i++)
massive[i]=i *i;
Заполняет массив квадратами индексов
ilyxa08
1) Поля "Название", "Материк", "Куда впадает" - это символьный тип.Поля "Длина (в км)" и "Максимальная глубина (в м)" - это числовой тип.Поле "Наличие водохранилищ (имеются или нет)" - это логический тип. Первичный ключ таблицы - поле "Название".

2) 
Таблица может иметь например такую структуру:
 Участники
id (int "PRIMARY KEY"), surname (char), date_registration (date), confirm (bool)
 
В таблицу заносятся участники конференции
Описание полей:
id- идентификатор участника, числовой (целый), нужен для того чтобы можно было занести в базу данных 2 участников с одинаковой фамилией и суметь различить их.
surname - фамилия участника (тип данных символьный)
date - дата регистрации участника
confirm - поле определяющее поступила ли оплата участия в конференции от участника (FALSE  - не поступала, TRUE - поступала)  
 
Как может выглядеть таблица смотри в приложении 
 
Кроме того можно заменить поле confirm на поле "пол" для определения как обращаться к людям с фамилией например Бондарь (если допусти False, то считаем что мужчина, если True, то женщина, можно и наоборот) 
yfetyukov2

На Паскале:

Объяснение:

var a, b, c, d, x : real;

begin

 Write('Введите значение A: '); ReadLn(a);

 Write('Введите значение B: '); ReadLn(b);

 Write('Введите значение C: '); ReadLn(c);

 WriteLn;

 d := sqr(b) - 4 * a * c;

 if (a = 0) and (b = 0) and (c = 0) then

 begin

   WriteLn('X - любое число.');

 end else if (a = 0) and (b = 0) then

 begin

   WriteLn('Заданное уравнение не имеет решений!');

 end else if (a = 0) then

 begin

   WriteLn('Старший коэффициент не может равняться нулю.');

   WriteLn('В этом случае уравнение преобразуется в линейное.');

   x := (-c) / b;

   WriteLn('X = ',x:2:2);

 end else if ((a <> 0) and (b <> 0)) then

 begin

   if (d > 0) then

   begin

     WriteLn('D = ',d:2:2);

     WriteLn('Корень D = ',sqrt(d):2:2);

     x := ((-b) + sqrt(d)) / (2 * a);

     WriteLn('X1 = ',x:2:2);

     x := ((-b) - sqrt(d)) / (2 * a);

     WriteLn('X2 = ',x:2:2);

   end else if (d < 0) then

   begin

     WriteLn('D = ',d:2:2);

     WriteLn('D < 0, поэтому уравнение не имеет решений!');

   end else if (d = 0) then

   begin

     x := (-b) / (2 * a);

     WriteLn('D = ',d:2:2);

     WriteLn('X = ',x:2:2);

   end;

 end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которая заполняет массив значением квадратов индексов элементов
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

s-food
natkuv7
Сергеевич
Aleksandrovich-Mayatskikh
AndreiFaikov1943
arionul-secondary2
lider123
artemkolchanov24
Оксана Анна
krylova-natali
D-posilochka
yana2211
sv-opt0076
Solovetzmila
konstantin0112