Ruzalina_Svetlana1435
?>

Напишите программу, которая находит среднее значение четных и нечетных чисел из одного файла и записывает ответ в другой файл ( из файла in.txt в out.txt) паскаль пример 6 - (кол-во чисел) 1 2 3 4 5 6 среднее значение чётных среднее значение нечётных

Информатика

Ответы

Zashchitin Denis
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var s:=ReadLines('in.txt').ToArray;
  var n:=StrToInt(s[0]);
  var a:=s[1].ToWords.Select(e->StrToInt(e)).ToArray;
  var f:=OpenWrite('out.txt');
  Writeln(f,n,' - (кол-во чисел)');
  foreach var e in a do Write(f,e,' '); Writeln(f);
  Writeln(f,'Среднее значение четных ',
    a.Where(x->x.IsEven).Average);
  Writeln(f,'Среднее значение нечетных ',
    a.Where(x->x.IsOdd).Average);
  f.Close
end.

Файлы in.txt и out.txt находятся во вложении.

Содержимое файла out.txt:
15 - (кол-во чисел)
-22 49 33 47 -10 -1 20 -18 2 21 2 -25 21 -47 -36
Среднее значение четных -8.85714285714286
Среднее значение нечетных 12.25
Galinova2911

Python 3.7.0

Лови, прикрепил фото с результатами, посмотри(т.е сразу выводит, после "следующий")


count = int(input("Количество событий: "))

queue = []      # очередь

for i in range(count):

   event = input()

   if "Кто последний?" in event:

       queue.append(event[19:len(event) - 1])

   if "Я только спросить!" in event:

       queue.insert(0, event[23:len(event) - 1])

   if "Следующий!" in event:

       if queue:

           print("Заходит " + queue.pop(0) + "!")

       else:

           print("В очереди никого нет.")


Окунёмся в суровый и беспощадный мир очереди на приём к врачу в поликлинике. напишем программу-медсе
mikek0906

Функция нахождения индекса макс. числа массива:

int max, maxl, counter;

max = array[0];

 for(int i = 0; i < size; i++){

  if (array[i] > max) {

       max = array[i];

       maxI = i;

      }

 }

Дальше проходимся по массиву от нулевого элемента и до макс.элемента и ищем чётные числа:

counter = 0;

for (int i=0; i<maxl; i++)

{

   if ( array[i]%2 != 0)

       counter++;

}

printf( "number of odd numbers is: %d", counter);

Должно заработать, только оформите как подобает, если нет - обращайтесь, починим )

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая находит среднее значение четных и нечетных чисел из одного файла и записывает ответ в другой файл ( из файла in.txt в out.txt) паскаль пример 6 - (кол-во чисел) 1 2 3 4 5 6 среднее значение чётных среднее значение нечётных
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Wunkamnevniki13438
gbfedak220
appmicom
ale-protasov
orange-salon-job77
nsh25044
printdecor
Olga1233
natalyaionova
delfinmos
allo22-27
игнатова_Сергей1228
Хохлов
iracaenko153
ann328389
▲