program amountnumbers3;
var
quantity, amount, number, counter: integer;
begin
counter := 0;
amount := 0;
write('Введите количество чисел: ');
read(quantity);
while counter <> quantity do
begin
read(number);
if (number mod 3 = 0) then
inc(amount, number);
inc(counter);
end;
write('Сумма чисел, кратных 3 = ', amount);
end.
Объяснение:
program amountnumbers3; // Название программы
var
quantity, amount, number, counter: integer; // Создание целочисленных переменных:
quantity - количество чисел в последовательностиamount - сумма чисел, кратных 3number - числа - переменная счетчикbegin // Начало программы
counter := 0; // Переменная счетчик = 0
amount := 0; // Переменная, хранящая сумму = 0
write('Введите количество чисел: '); // Вывод сообщения в консоль
read(quantity); // Считывание количества чисел в последовательности с клавиатуры
while counter <> quantity do // Пока значение переменной counter ≠ значению переменной quantity, выполняй
begin // Начало цикла
read(number); // Считываем число последовательности с клавиатуры
if (number mod 3 = 0) then // Если остаток от деления при делении значения переменной number на 3 = 0, тогда
inc(amount, number); // Увеличиваем значение переменной amount на number
inc(counter); // Увеличиваем значение переменной counter на единицу
end; // Конец цикла
write('Сумма чисел, кратных 3 = ', amount); // Вывод ответа
end. // Конец программы
IP-адрес (aй-пи адрес, сокращение от англ. Internet Protocol Address) — уникальный идентификатор (адрес) устройства (обычно компьютера) , подключённого к локальной сети или интернету.
IP-адрес состоит из двух частей: номера сети и номера узла. В случае изолированной сети её адрес может быть выбран администратором из специально зарезервированных для таких сетей блоков адресов (192.168.0.0/16, 172.16.0.0/12 или 10.0.0.0/8). Если же сеть должна работать как составная часть Интернета, то адрес сети выдаётся провайдером либо pегиональным интернет-регистратором (Regional Internet Registry, RIR).
IP-адрес представляет собой 32-битовое (по версии IPv4) или 128-битовое (по версии IPv6) двоичное число. Удобной формой записи IP-адреса (IPv4) является запись в виде четырёх десятичных чисел (от 0 до 255), разделённых точками, например, 192.168.0.1. (или 128.10.2.30 — традиционная десятичная форма представления адреса, а 10000000 00001010 00000010 00011110 — двоичная форма представления этого же адреса).
Объяснение:
Поделитесь своими знаниями, ответьте на вопрос:
Дано четырехразрядное натуральное число, если оно четное, то найти сумму разрядов, если нет - сумму квадратов. (кумир или паскаль написать программу полностью)