Равиль_Евгеньевич1808
?>

Составьте программу, находящую сумму квадратов первых n чисел.используя цикл с предусловием, там

Информатика

Ответы

mail5
For(i = 0; i < N; i++)
{
  sum += a[i] * a[i];
}
energycomplect5914
1. В приведенном коде ошибка. Не хватает ";" в третьей строке снизу.
2. Немного изменим ваш код и получим искомое значение x
Искомое число х = 16293

var
  x, y, a, b, k: integer;

begin
  k:=10000;
  repeat
    x:=k;
    a := 0; b := 0; y := 1;
    while x > 0 do
    begin
      if (x mod 10) mod 2 = 0
        then
        a := a * 10 + x mod 10
      else begin
        y := y * 10;
        b := b * 10 + x mod 10
      end;
      x := x div 10
    end;
    a := a * y + b;
    k := k + 1;
    until a = 26391;
    writeln(a:8, k-1:8); 
end.

 
ВитальевичЕвгеньевич346
// PascalABC.NET 3.1, сборка 1230 от 27.04.2016
begin
  var n:=ReadInteger('n=');
  var a:=MatrixRandom(n,n,10,99);
  var s:=0;
  var k:=0;
  for var i:=0 to n-1 do begin
    for var j:=0 to n-1 do Print(a[i,j]);
    Writeln;
    if a[i,i].IsEven then begin s+=a[i,i]; Inc(k) end;
    end;
  if k>0 then Writeln('S=',s/k:0:2)
  else Writeln('На главной диагонали нет четных элементов')
end.

Тестовое решение
n= 8
63 13 33 90 25 21 87 91
88 88 48 13 30 59 81 27
73 23 76 77 52 19 33 97
53 87 13 74 17 35 61 70
77 96 51 61 82 33 63 22
39 88 84 54 88 73 74 69
76 26 69 14 45 80 70 54
80 36 47 38 18 22 84 62
S=75.33

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, находящую сумму квадратов первых n чисел.используя цикл с предусловием, там
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mariy-inkina8
baranovaas
alexfold
Vladimirovna1370
impuls20125948
Сергей
uisfbu7777733
Anna_Kamil
озерская_Мария1234
seletan1
goldglobustour725
Сергеевна-Иван1045
galereyaas1568
reznikvi
Antonov-Elena
▲