serkinn69
?>

Дан массив из 10 элементов вывести на экран так чтобы на первом месте стояло минимальное число а на последнем максимальное

Информатика

Ответы

vovkiv7864
Program sh;   var j: integer;   massiv: array [1..1000] of integer;   begin;     begin;       randomize;       for j: =1 to 1000 do         massiv[j]: =random(1000);     end;     for j: =1 to 1000 do       begin;         if (massiv[j] mod 1=0) then         if (massiv[j]> 0) and (massiv[j] mod massiv[j]=0) then         write (massiv[j]: 5);       end;   end. я не понял запрос, в итоге эта программа выводит все натуральные числа созданные рандомом в районе от 0 до 1000.
marketing6

е задание: «Кодирование графической и звуковой

информации, объем и передача информации»

Уровень сложности — базовый,

Требуется использование специализированного

программного обеспечения — нет,

Максимальный — 1,

Примерное время выполнения — 5 минут.

Проверяемые элементы содержания: Умение определять

объём памяти, необходимый для хранения графической и

звуковой информации

Задание 7_1:

ЕГЭ по информатике 2017 задание 7 (9) ФИПИ вариант 1 (Крылов С.С.,

Чуркина Т.Е.):

Какой минимальный объем памяти (в Кбайт) нужно зарезервировать,

чтобы можно было сохранить любое растровое изображение

размером 160 х 160 пикселей при условии, что в изображении могут

использоваться 256 различных цветов? В ответе запишите только целое

число, единицу измерения писать не нужно.

ответ: 25

Показать решение:

 Используем формулу нахождения объема:

I = M x N * i

 Подсчитаем каждый сомножитель в формуле, стараясь привести числа к

степеням двойки:

o M x N:

160 * 160 = 20 * 2³ * 20 * 2³ = 400 * 26 =

= 25 * 24 * 26

o Нахождение глубины кодирования i:

256 = 28

т.е. 8 бит на пиксель (из формулы кол-во цветов = 2i)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дан массив из 10 элементов вывести на экран так чтобы на первом месте стояло минимальное число а на последнем максимальное
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Taniagrachev
format-l3364
Владимирович_Слабый
Ingakazakova
kireevatatiana
opel81
ЕВгений_денис643
Tamara
svetarakityanskaya
Сергей_Крутикова114
egorsalnikov1997139
lazu8375
ekrosenergoserv
arturo95
igschuschkov6211
▲