1)Монитор,(на счет магнитофона не уверен, сам по себе именно магнитофон никак не является устройством ПК, но если подразумевают пол этим словом динамик ПК, то подходит)
2)Получение
3)Электрический ток
4)Анатомический муляж
5)102 бита
6)48
7)из перечисленных ниже нет верного ответа. 568 в десятичной = 1 000 111 000 в двоичной.
8)АВИБА
9)Представленные ответы неправильны, так как не являются двоичным кодом(присутствуют двойки)+не указано к какой системе счисления принадлежит y (если x - очевидно 16-ти ричная, то y может быть как 16 так и 10
10) И снова нет верного ответа из предложенных, т.к. получится D8
11)800 бит
12) (Ячейки excel где?)
13) Аналогично 12
14)тоже
15)27
16)User-name
17)c*.c*
18)145.92.128.0
19)Верного ответа нет. Правильно: 22
20) 5
Объяснение:
Можно код сделать покороче, если ты об этом.
program tri;
var
a, b, c: real;
begin
writeln('Введите a,b,c:');
readln(a, b, c);
if (a > 0) and (b > 0) and (c > 0) then
begin
if (a = c) and (b = c) and (a = b) then
writeln('Треугольник равносторонний') ;
if (((a = b) and (b <> c)) or
((b = c) and (b <> a)) or
((c = b) and (c <> a))) then
writeln('Треугольник равнобедренный');
if (a <> b) and (c <> b) and (a <> c) then
writeln('Треугольник произвольный') ;
end
else
writeln('такого треугольника нет') ;
end.
Ну вот, на 5 строчек короче, но смысл тот же.
Изменения:
Использовал if.. else вместо двух if при проверке положительности сторон. Собрал 3 if при проверке на равносторонность в один if.Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу , которая определяет , сколько раз встречается в строке слог "ma";
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
Writeln('Количество "МА" равно ',
ReadlnString('>').MatchValues('МА',RegexOptions.IgnoreCase).Count)
end.
Тестовое решение
> Мама мыла раму. Маша ела мандарины.
Количество "МА" равно 4