Seid-ZadeNadezhda1769
?>

написать программу для создания чисел, состоящих из двух одинаковых чисел из заданного диапазона. например: из 210345 и 210345 должно получиться 210345210345 , из 210666 и 210666 - 210666210666 диапазон - от 100000000000 до 400000000000 похожая программа выложена на но там создавались зеркальные числа: 1221, 123321 за внимание.

Информатика

Ответы

РубенШафетдинов
// PascalABC.NET 3.1, сборка 1239 от 08.05.2016
begin
  Writeln(ReadlnString('Введите исходное число:')*2)
end.

Тестовое решение
Введите исходное число: 210345
210345210345
Karina-evgenevna1899
Var
 a:longint;
Begin
 write('Введите число: ');
 readln(a);
 writeln('Вывод: ',a,a)
End.
samsakovs7757
Свойства многострочного текстового поля. Для ввода и вывода значений элементов одномерного массива можно воспользоваться многострочным полем (компонент типа ТМеmо), который можно разместить на форме так же, как и другие компоненты. Среди свойств этого компонента есть много таких, которые имели ранее рассмотренные нами компоненты: Name, Color, Font, Enabled, Visible, Height, Width, Top, Left и in. Среди свойств, которых не было предыдущие компоненты, рассмотрим следующие:
ScrollBars (англ. Scroll - прокрутка, bars - прямоугольные полосы) - значение этого свойства определяет наличие или отсутствие на этом компоненте полос прокрутки (горизонтальной - ssHorizontal, вертикальной - ssVertical обоих - ssBoth) для просмотра текста, который выходит за пределы компонента;
ReadOnly (англ. Read - читать, only - только) - значение этого свойства определяет возможность редактирования строк компонента: False - можно редактировать, True - нельзя (только для чтения)
Lines (англ. Lines - линии, строки) - значением этого свойства является набор значений, расположенных в строках этого компонента; каждая строка имеет номер, нумерация строк начинается с 0;
Lines.Count (англ. Count - подсчет) - значение этого свойства равно количеству заполненных данными строк компонента; отметим, что это свойство отсутствует в списке свойств окна Object Inspector.
Тогда при сохранении проекта эти значения также будут сохранены и автоматически появятся в этом поле после запуска проекта на выполнение.
YekaterinaAbinskov

Відповідь:

Ввести три числа и найти их сумму и произведение

#include <iostream>

using namespace std;

int main(){

setlocale(LC_ALL , "Rus");

int a,b,c,sum,product;

cout << "a: ";

cin >> a;

cout << "b: ";

cin >> b;

cout << "c: ";

cin >> c;

sum = a+b+c;

product = a * b * c;

cout << "Сума = " << sum << endl;

cout << "Произведение = " << product << endl;

       return 0;

}

Ввести три числа найти их сумму произведение и среднее арифметическое#include <iostream>

using namespace std;

int main(){

setlocale(LC_ALL , "Rus");

int a,b,c,sum,product;

float average;

cout << "a: ";

cin >> a;

cout << "b: ";

cin >> b;

cout << "c: ";

cin >> c;

sum = a+b+c;

product = a * b * c;

average = (a+b+c) / 3.;

cout << "Сума = " << sum << endl;

cout << "Произведение = " << product << endl;

cout << "Среднее арифметическое = " << average << endl;

return 0;

}

Ввести три числа и найти наибольшее из них

#include <iostream>

using namespace std;

int main(){

setlocale(LC_ALL , "Rus");

int a,b,c,sum,product;

float average;

cout << "a: ";

cin >> a;

cout << "b: ";

cin >> b;

cout << "c: ";

cin >> c;

if(a > b && a > c){

 cout << "Наибольшее число : " << a << endl;

}

if(b > a && b > c){

 cout << "Наибольшее число : " << b << endl;

}

if(c > a && c > b){

 cout << "Наибольшее число : " << c << endl;

}

return 0;

}

Ввести пять чисел и найти наибольшее из них

#include <iostream>

using namespace std;

int main(){

setlocale(LC_ALL , "Rus");

int a,b,c,d,e,sum,product;

float average;

cout << "a: ";

cin >> a;

cout << "b: ";

cin >> b;

cout << "c: ";

cin >> c;

cout << "d: ";

cin >> d;

cout << "e: ";

cin >> e;

if(a > b && a > c && a > d && a > e){

 cout << "Наибольшее число : " << a << endl;

}

if(b > a && b > c && b > d && b > d){

 cout << "Наибольшее число : " << b << endl;

}

if(c > a && c > b && c > d && c > e){

 cout << "Наибольшее число : " << c << endl;

}

if(d > a && d > b && d > c && d > e){

 cout << "Наибольшее число : " << d << endl;

}

if(e > a && e > b && e > c && e > d){

 cout << "Наибольшее число : " << e << endl;

}

return 0;

}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

написать программу для создания чисел, состоящих из двух одинаковых чисел из заданного диапазона. например: из 210345 и 210345 должно получиться 210345210345 , из 210666 и 210666 - 210666210666 диапазон - от 100000000000 до 400000000000 похожая программа выложена на но там создавались зеркальные числа: 1221, 123321 за внимание.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yakovlevasvetlanalvovna209
hrviko
yuliasam
dawlatowajana
gymnazium
ann328389
kosharikclub
jstepanova
konstantinslivkov
buhh20104519
magnit-expo
sov0606332
NataliaBerezovskaya33
соловьев_Куркина
ska67mto3983