rimmaskis
?>

Составьте программу рисования квадрата с вершинами лежащим на осях координат координаты одной из вершин (0; 11)

Информатика

Ответы

Люблянова_Р.1777
Uses GraphABC;
begin
    Rectangle(0, 0, 11, 11);
end.
fursov-da
Алгоритм решения

Для начала давай посмотрим на года.

1. Если разница между годом рождения и текущим годом больше 16, мы однозначно можем сказать, что человеку уже есть 16.

2. Если разница между годом рождения и текущим годом меньше 16, мы однозначно можем сказать, что человеку ещё нет 16.

Если разница между годом рождения и текущим годом равна 16, мы можем сказать, что у человека день рождения в этом году. Давай глянем на месяц.

1. Если текущий месяц больше месяца рождения, человеку уже есть 16.

2. Если текущий месяц меньше месяца рождения, человеку ещё нет 16.

Если у человека день рождения в этом месяце, давай точно так же глянем на дни.

В итоге мы уже точно знаем, когда у человека день рождения.


Код решения

#include <bits/stdc++.h>

using namespace std;


int main() {

   int d1, m1, y1, d2, m2, y2;

   cin >> d1 >> m1 >> y1 >> d2 >> m2 >> y2;

   if (y2 - y1 > 16) {

       cout << "YES" << endl;

       return 0;

   } else if (y2 - y1 < 16) {

       cout << "NO" << endl;

       return 0;

   }

   if (m2 > m1) {

       cout << "YES" << endl;

       return 0;

   } else if (m2 < m1) {

       cout << "NO" << endl;

       return 0;

   }

   if (d2 < d1) {

       cout << "NO" << endl;

       return 0;

   }

   cout << "YES" << endl;

   return 0;

}


Файл решения прикреплён.

m-illarionov
1) Символом может быть и пиктограмма и какая-нибудь буква, цифра, знаки препинания. А пиктограмма это исключительно условное изображение явлений, предметов и т. д.
2 ) В данной статье приведены практические рекомендации, комплексы упражнений и различные меры, благодаря которым человек, работающий за компьютером может сам, собственными усилиями, нейтрализовать отрицательное воздействие компьютера на организм зрению, мышечной и опорно-двигательной системе справиться со значительными статическим нагрузками.

При условии внимательного отношения к своему здоровью - вам удастся избежать проблем с онемением пальцев рук из-за т.н. "туннельного синдрома", серьезных дегенеративно-дистрофических изменений шейного отдела позвоночника и многих других, которые в первую очередь не позволят вам работать... за компьютером. Ну а для основной массы интеллигентного населения - это беда, последствия которой известны...

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу рисования квадрата с вершинами лежащим на осях координат координаты одной из вершин (0; 11)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Coffee3862
Кристина910
ninakucherowa
guujuu
Лилин1079
тахирович_Игорь581
КОРМИЛИЦЫНА
innaterenina
svt5299
murin
alakhverdov138
Oslopova
mikchaylovaalex
maxkuskov2485
o-kate17
▲