nataliaterekhovasinger2
?>

Синформатикой. pascal abc. 25 блоха и куб. блоха находится в вершине куба. за один прыжок она может переместиться в любую соседнюю вершину. сколькими различными путями она ровно за n прыжков может оказаться в противоположной вершине? нужно написать программу для pascal !

Информатика

Ответы

nord0764
Представим куб в виде графа его каркаса. Пронумеруем все вершины куба цифрами от 1 до 8. Задача сводится к обычному обходу в ширину. Для четных N ответ будет 0, т.к. нельзя дойти на противоположную вершину за четное кол-во шагов. ответ будет расти в геометрической прогрессии в зависимости от N. Программа:

const
  m: array[1..8, 1..8] of byte = 
 ((0, 1, 1, 1, 0, 0, 0, 0),
  (1, 0, 0, 0, 1, 0, 1, 0),
  (1, 0, 0, 0, 1, 1, 0, 0),
  (1, 0, 0, 0, 0, 1, 1, 0),
  (0, 1, 1, 0, 0, 0, 0, 1),
  (0, 0, 1, 1, 0, 0, 0, 1),
  (0, 1, 0, 1, 0, 0, 0, 1),
  (0, 0, 0, 0, 1, 1, 1, 0));
  
var
  n, i, j, k: integer;
  a: array[0..100, 1..8] of int64;
begin
  read(n);
  a[0, 1] := 1;
  for k := 1 to n do
    for i := 1 to 8 do
      for j := 1 to 8 do
        if m[i, j] = 1 then
          a[k, i] := a[k, i] + a[k - 1, j];
  write(a[n, 8]);
end.
skorpion7228528

Запишу на обычном языке, Паскаль не помню уже.

А - первое число. Б - второе число.

Если А больше Б и Б div 5=0 тогда выводится на экран (' Б наименьшее число и нацело делится на 5')

Если Б больше А и А div 5=0 тогда выводится на экран (' А наименьшее число и нацело делится на 5')

 

Точно не помню как выглядит это в Паскале, но что-то типо такого

If A<B and A div 5=0 then writeln ('А наименьшее число и нацело делится на 5');

If B<A and B div 5=0 then writeln ('Б наименьшее число и нацело делится на 5');

vyborovvs

Целое, целочисленный тип данных (англ. Integer), в информатике — один из и самых рас типов данных в языках программирования. Служит для представления целых чисел.

Множество чисел этого типа представляет собой конечное подмножество бесконечного множества целых чисел, ограниченное максимальным и минимальным значениями.

В программировании различают беззнаковые целые числа и целые числа со знаком. Знак числа обычно кодируется старшим битом машинного слова. Традиционно, если старший бит равен 1, то число считается отрицательным, только, если оно не определено как беззнаковое.

Количество чисел в машинном

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Синформатикой. pascal abc. 25 блоха и куб. блоха находится в вершине куба. за один прыжок она может переместиться в любую соседнюю вершину. сколькими различными путями она ровно за n прыжков может оказаться в противоположной вершине? нужно написать программу для pascal !
Ваше имя (никнейм)*
Email*
Комментарий*