mmurzina
?>

Составить программу вычисления значения функции y=3x^2-x+2 если x(-2; 2) и изменяется с шагом x=0, 4

Информатика

Ответы

annazhurawlewa
Var
    y, x, h: real;

begin
    x := -2.0;
    h := 0.4;
    repeat
        y := 3 * x * x - x + 2;
        writeln(x, ' ', y);
        x := x + h;
    until x > 2
end.
vetviptime
Код Pascal:

Const
   N = 4;
Var
   A:array[1..N,1..N] of integer;
   i,j:integer;
   S:real;
Begin
Randomize;
WriteLn('Исходный массив:');
For i:= 1 to N do
    Begin
    For j:= 1to N do
        Begin
        A[i,j]:=random(21)-10;
        Write(A[i,j]:3,' ')
        End;
    WriteLn
    End;
S:=0;
For i:= 1 to N do
    S:=S+A[i,i]+A[N-i+1,i];
WriteLn('Сумма диагональных элементов: ',S)
End.

Пример работы программы:

Исходный массив:
  5   6  -3  -5
 -1  -1   6   1
 -3  -7   7  -5
 -1  -2   2   9
Сумма диагональных элементов: 13
dmitrymakarov003
// PascalABC.NET 3.2, сборка 1485 от 15.06.2017
// Внимание! Если программа не работает, обновите версию!

procedure MaxR(a:array[,] of integer; var b:array of integer);
begin
  b:=a.Rows.Select(r->r.Select(x->x).Max).ToArray
end;

begin
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(4,3,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  var b:array of integer;
  MaxR(a,b);
  Write('Максимумы построчно: '); b.Println
end.

Пример
*** Исходный массив ***
  18 -32 -82
  31  44 -16
 -32 -28   2
 -14  -6 -82

Максимумы построчно: 18 44 2 -6

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления значения функции y=3x^2-x+2 если x(-2; 2) и изменяется с шагом x=0, 4
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nadezhda Malakhov53
elena
serge-lysoff
Аверьянова
Margarita
cheberyako2013
Нина1449
novocherkutino7
pronikov90
vbnm100584
makovei78
servik78
oduvanalex
Faed_Arakcheeva
bei07