dmitzu8594
?>

Написать программу в turbo pascal. клавиатуры вводится однозначное число. если это число совпадает с заданным, то программа заканчивается, в противном случае она просит повторно ввести однозначное число

Информатика

Ответы

verkop9

Program zn1;

uses CRT;

var a,b,m,n,i,j,g:integer;

Begin

     clrscr;

     write ('Задайте число: ');

     readln (a);

     write ('Введите число: ');

     readln (b);

     If a<>b then

        Repeat

введите повторно число: ');

        readln (b);

        until a=b

     Else

     if a=b then

        Begin

        end;

End.

 Держи.

vak1984
Как соотношение выбранного и максимального случайного числа.

Код:

#include <iostream>
#include <cstdlib>
#include <ctime>
using namespace std;

int randFloatTo(float x)
{
float ret = static_cast <float> (rand()) / (static_cast <float> (RAND_MAX/x));
return ret;
}

int main()
{
srand(time(NULL));
int size;
cout << "Размер массива: ";
cin >> size;
cout << endl << "Массив:" << endl;
float arr[size];
for (int i = 0; i < size; i++) {
arr[i] = randFloatTo(rand());
cout << arr[i] << ' ';
}
return 0;
}
tanyashevvvv
// PascalABC.NET 3.2, сборка 1437 от 03.05.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=MatrRandom(6,3,-99,99);
  a.Println(4); Writeln(4*a.ColCount*'-');
  a.Rows.Select(r->r.Where(x->x>0).Sum).Print;
  Println(' - суммы положительных');
 
  Writeln;
  var z:=MatrRandom(3,5,-10,20);
  z.Println(4); Writeln(4*z.ColCount*'-');
  z.Rows.SelectMany(x->x).Where(x->(x>0) and (x<15)).Println
end.

Пример
 -67  56 -68
  16 -59 -82
 -54 -44  90
  82  95  39
 -44  60  22
 -97  82  23

56 16 90 216 82 105 - суммы положительных

   7  -5  -3   5  -7
   3   5  -8  14  -6
  12  14  19  14  -7

7 5 3 5 14 12 14 14

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в turbo pascal. клавиатуры вводится однозначное число. если это число совпадает с заданным, то программа заканчивается, в противном случае она просит повторно ввести однозначное число
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

randat887040
festjob
isinyakin
barnkim
Tanyamitia
bessalaias
schernov
Stepanovich_Makarov
cmenick29
kolyabelousow4059
Golovinskii_Sirotkina1944
Yevgenevna
vsemvsego306
Александрович Андреевна
mihalewanadia20176987