Caragyant
?>

Паскаль. дан текст. написать программу, которая подсчитывает количество слов, в тексте учитывая, что между словами может быть по несколько пробелов.

Информатика

Ответы

Vitalevich1799
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var s:=ReadlnString('Вводите:');
  Write('Кол-во слов: ',s.ToWords.Count)
end.

Тестовое решение
Вводите: А роза     упала     на лапу   Азора
Кол-во слов: 6
bhg50

Объяснение:

базовое программное обеспечение (base software) – минимальный набор программных средств, обеспечивающих работу компьютера.

в него входят операционная система (предназначена для управления выполнением пользовательских программ, управления вычислительными ресурсами), операционные оболочки (сециальные программы, которые предназначены для упрощения работы пользователя с командами операционной системы, имеют текстовый и графический варианты интерфейса), сетевая операционная система (комплекс программа, который обеспечивает обработку, передачу и хранение данных в сети).

Dlyamila

Объяснение:

PascalABC.NET. Версия 3.5.1, сборка 2261 (4.11.2019)Задание 1

program abc;

const n=2; // Задание начальных параметров массива через константы

const m=2;

var C:array[1..n,1..m] of integer;

A:array[1..n,1..m] of integer;

B:array[1..n,1..m] of integer;

i,j:integer;

begin

 for i:=1 to n do

   for j:=1 to m do

    begin

     readln(A[i,j]); // Ввод данных и вычисление по формуле

     readln(B[i,j]);

     C[i,j]:=A[i,j]+B[i,j];

    end;

  writeln('C[n,m] = ');

  for i:=1 to n do

   begin

    for j:=1 to m do

     write(C[i,j],' '); // Вывод массива

    writeln;

   end;

end.

Задание 2

program abc;

const n=3; // Задание начальных параметров массива через константы

const m=3;

var A:array[1..n,1..m] of integer;

i,j:integer;

begin

 for i:=1 to n do

   for j:=1 to m do  // Ввод данных массива

     readln(A[i,j]);  

     

 writeln('Оригинальный массив A(n,m):');

 

 for i:=1 to n do  // Вывод оригинального массива

   begin

    for j:=1 to m do

      write(A[i,j],' ');

    writeln;

   end;

  for i:=1 to n do // Замена 2-ого столбца 2-ой строкой

   A[i,2]:=A[2,i];

   

   writeln('Изменённый массив A(n,m):');

     

   for i:=1 to n do // Вывод изменённого массива

   begin

    for j:=1 to m do

      write(A[i,j],' ');

    writeln;

   end;

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Паскаль. дан текст. написать программу, которая подсчитывает количество слов, в тексте учитывая, что между словами может быть по несколько пробелов.
Ваше имя (никнейм)*
Email*
Комментарий*