gusinica23
?>

Написать программу в паскаль. дан массив целых чисел. найти количество пар соседних элементов, в которых одно число четное, а другое отрицательное. выведите также сформированный массив и все искомые пары соседних элементов.

Информатика

Ответы

Александр Джабраиловна1967
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:=ArrRandom(ReadInteger('n='),-99,99); a.Println;
  var b:=a.Pairwise; b.Println;
  Writeln('Найдено пар: ',
    b.Where(x->(x[0]<0) and x[1].IsEven or
      (x[1]<0) and x[0].IsEven).Count)
end.

Тестовое решение
n= 10
-37 -71 -71 -65 73 -66 -33 -85 62 -92
(-37,-71) (-71,-71) (-71,-65) (-65,73) (73,-66) (-66,-33) (-33,-85) (-85,62) (62,-92)
Найдено пар: 3
demakova1969

Вся история развития человеческого общества связана с накоплением и обменом информацией (наскальная живопись, письменность, библиотеки, почта, телефон, радио, счеты и механические арифмометры и др.).

Коренной перелом в области технологии обработки информации начался после Второй мировой войны.

В вычислительных машинах первого поколения основными элементами были электронные лампы. Эти машины занимали громадные залы, весили сотни тонн и расходовали сотни киловатт электроэнергии. Их быстродействие и надежность были низкими, а стоимость достигала 500-700 тысяч долларов.

bulk91675
#!/usr/bin/env python
# coding: utf-8
"""Определение типа треугольника по сторонам.
Python 2.X.
"""

msg = 'Введите стороны треугольника: '
input = raw_input(msg).split()

try:
    a, b, c = [float(i) for i in input]
except ValueError:
    print('Введены не числовые значения! Выход...')
    quit()

if (a >= b + c or
    b >= a + c or
    c >= a + b):
    print('Не', end=' ')
elif a ** 2 + b ** 2 == c ** 2:
    print('Прямоугольный', end=' ')
elif (a ** 2 + b ** 2 > c ** 2 and
      a ** 2 + c ** 2 > b ** 2 and
      c ** 2 + b ** 2 > a ** 2):
    print('Остроугольный', end=' ')
else:
    print('Тупоугольный', end=' ')
print('треугольник')

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскаль. дан массив целых чисел. найти количество пар соседних элементов, в которых одно число четное, а другое отрицательное. выведите также сформированный массив и все искомые пары соседних элементов.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Васильевичь Виктория457
egoryandiana3727283
marinakovyakhova
amarantmetall
Троцкая-Ивановна
АнжелаВасильевич
ea-office
Анатольевич-Митюшин
moskvabelarus
Александровна1685
Попов1946
apioslk4533
victoriapetrs
lepekhov4011
Lusiarko65