lukur2005
?>

Дано целое число а. если значение а< > 0, то необходимо уменьшить его на 4. написать программу для решения этой . программа должна иметь дружественный интерфейс.

Информатика

Ответы

petrowanastya202081
Program chisloA;
Var a:longint;
Begin
  readln(a);
If a<>0 then a:=a-4;
  writeln(a);
End.
unalone5593
A = int(input())
if A > 0 or A < 0:
    A -= 4
abahtina582
1 на одном языке программирования написали другой
2 текст на английском нужно перевести на русский дабы все пользователи поняли, и конечно же переведенный мануал где нить как нить запомнили(хоть в электронном виде хоть распечатали, хоть от руки написали)
3 ОГРОМНАЯ база данных хранит огромное количество данных на всем предприятии, ее разбили на части и дали каждому отделу лишь то что необходимо им
4 пришел к другу копирнул фильм на флешку, дабы посмотреть дома
5 мне сказали что нельзя совать вилку в розетку(вроде причину я тогда еще не понял, но воспринял и не совал)
6 передаем сообщение(хоть смс, хоть азбуку морзе) везде есть измерения количества информации, а здесь зачастую спрашивают минимальное количество информации необходимое для передачи маленьких сообщений
7 мне по скайпу кинули картинку я ее принял
8 а вот пока мне ее кидали я ее принимал, был процесс передачи
9 вирус залез на комп и стер базу данных какую нить
10 идентично 8 же разве нет?
kolyabelousow4059

ответ:Решение

АЛГОРИТМ МАЛЕНЬКИЕ КВАДРАТЫ

алг квадраты_1

нач

   нц 5 раз

      опустить перо

      сместиться на вектор (2, 0)

      сместиться на вектор (0, 2)

      сместиться на вектор (- 2, 0)

      сместиться на вектор (0, - 2)

      поднять перо

      сместиться на вектор (3, 0)

         опустить перо

         сместиться на вектор (1, 1)

         сместиться на вектор (- 1, 1)

         сместиться на вектор (- 1, - 1)

         сместиться на вектор (1, - 1)

      поднять перо

   кц

кон

АЛГОРИТМ БОЛЬШИЕ КВАДРАТЫ

алг квадраты_2

нач

   нц 4 раз

      опустить перо

      сместиться на вектор (2, 0)

      сместиться на вектор (0, 2)

      сместиться на вектор (- 2, 0)

      сместиться на вектор (0, - 2)

      поднять перо

      сместиться на вектор (4, - 1)

         опустить перо

         сместиться на вектор (2, 2)

         сместиться на вектор (- 2, 2)

         сместиться на вектор (- 2, - 2)

         сместиться на вектор (2, - 2)

      поднять перо

   кц

кон

АЛГОРИТМ ПРЯМОУГОЛЬНИКИ

алг прямоугольники_1

нач

   нц 5 раз

      опустить перо

      сместиться на вектор (0, 1)

      сместиться на вектор (- 3, 0)

      сместиться на вектор (0, - 2)

      сместиться на вектор (3, 0)

      сместиться на вектор (0, 1)

      

      сместиться на вектор (- 1, 0)

      сместиться на вектор (0, - 2)

      сместиться на вектор (3, 0)

      сместиться на вектор (0, 2)

      сместиться на вектор (- 2, 0)

      поднять перо

      сместиться на вектор (4, 0)

   кц

кон

АЛГОРИТМ УЗОР

алг часть_1

нач

   нц 4 раз

      опустить перо

      сместиться на вектор (0, 2)

      сместиться на вектор (2, 0)

      поднять перо

      сместиться на вектор (- 3, - 1)

   кц

кон

алг часть_2

нач

   нц 4 раз

      опустить перо

      сместиться на вектор (0, 2)

      сместиться на вектор (- 2, 0)

      поднять перо

      сместиться на вектор (3, - 1)

   кц

кон

алг часть_3

нач

   нц 4 раз

      опустить перо

      сместиться на вектор (2, 0)

      сместиться на вектор (0, 2)

      поднять перо

      сместиться на вектор (- 1, - 3)

   кц

кон

алг часть_4

нач

   нц 4 раз

      опустить перо

      сместиться на вектор (0, - 2)

      сместиться на вектор (2, 0)

      поднять перо

      сместиться на вектор (- 3, 1)

   кц

кон

использовать Чертежник

алг узор_1

нач

   часть_1

   сместиться на вектор (5, - 5)

   часть_2

   сместиться на вектор (- 3, - 7)

   часть_3

   сместиться на вектор (- 7, 3)

   часть_4

кон

АЛГОРИТМ УЗОР 2

использовать Чертежник

алг узор_2

нач

   часть_3

   сместиться на вектор (4, 3)

   часть_4

   сместиться на вектор (1, - 6)

   часть_1

   сместиться на вектор (- 9, 2)

   часть_2

кон

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано целое число а. если значение а< > 0, то необходимо уменьшить его на 4. написать программу для решения этой . программа должна иметь дружественный интерфейс.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Dmitrii_Shamilevich2019
likakedo4ka439
rinat
buhtovarish
praktikadok
anton-www1
zaravshan20134
Monstr13
svo1961
is0019
spadikov
Chopper-hinter25
kalterbrun
dmitrymakarov003
info36
▲