Usynin-nikolay
?>

Написать программу в паскаль: ) дан произвольный текст на языке. написать программу, которая выводит слова, начинающиеся с гласной буквы и содержащие не менее двух согласных.

Информатика

Ответы

abroskin2002
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
function IsGl(c:char):=Pos(c,'АEЁИОУЫЭЮЯаеёиоуыэюя')>0;

begin
  var w:=ReadlnString('>').ToWords;
  foreach var v in w do
    if (v.Length>2) and IsGl(v[1]) then
      if v.ToCharArray.Skip(1).Where(c->not IsGl(c)).Count>=2
      then Println(v);
end.

Тестовое решение
> Очень непросто найти подходящие слова для осмысленных фраз - оно и понятно
Очень
осмысленных
Karpova
Василий
Из условия задачи знаем, что он выбрал желтую "флэшку".
Он выбрал "флэшку", которая больше "флэшки" Пети. Значит, учитывая, что Егор купил "флэшку" на 16 Гб(см. объяснение ниже), то Василий мог купить устройство объемом 4 и 8 Гб. 8>4 => Василий купил гаджет размером 8 Гб.
Следовательно, Василий купил желтую "флэшку" на 8 Гб.

Егор
Знаем, что ему не понравилась "флэшка" красного цвета, значит, он выбрал либо зеленую, либо желтую. Но в условии сказано, что желтую "флэшку"купил Василий, значит, Егор купил "флэшку" зеленого цвета.

Из условия следует, что Егор купил "флэшку" размером, равную "флэшкам" Пети и Василия вместе взятых. Знаем, что у "флэшек" следующие размеры: 4 Гб, 8 Гб, 16 Гб. Предположим, Егор купил гаджет размером 4 Гб, тогда должно быть справедливо следующее: 4>8+16; 4>24. Однако, это неверно, значит, Егор не покупал "флэшку" на 4 Гб. Предположим, что размер устройства был 8 Гб => 8>4+16; 8>20. Это тоже не верно. Значит, Егор купил "флэшку" на 16 Гб. Проверим: 16>4+8; 16>12.
Следовательно, Егор купил зеленую "флэшку" на 16 ГБ.

Петя
Методом исключения понимаем, что Петя купил красную "флэшку". Методом исключения, Петя купил "флэшку" на 4 Гб.
Получаем, что Петя купил красную "флэшку" на 4 Гб.

Подходит 3 вариант из ответов.
Николаевна_Анна670

Писал в Visual Studio. Проверка при x = 5: y = 0.7 * 5^4 - 4.5 * 5^2 / e = 396,11

Считает в диапазоне от 5 до 10 включительно.

Код:

#include "stdafx.h"

#include <iostream>

#include <windows.h>

using namespace std;

int main()  

{

setlocale(LC_ALL, "Russian");

double exp = 2.71828;

for (int x = 5; x < 11; x++) // Значения от 5 до 10 включительно

{

 double y = (0.7 * x*x*x*x - 4.5 * x*x / exp);

 cout << "[x = " << x << "] y = " << y << endl;

}

return 0;

}

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в паскаль: ) дан произвольный текст на языке. написать программу, которая выводит слова, начинающиеся с гласной буквы и содержащие не менее двух согласных.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

kirieskamod262
tolyan791
diana0720
korotinadasha07
Алина Ракитин1730
BrezhnevaKoidula
Lugovoi
TOKAREVA Stepan
maksmi
a96849926288
Alekseevich_Viktorovna
Филипп1054
Бочкарева Горохова1652
Роман
Manyaya
▲