kseybar
?>

Срешить , составить программу в паскаль и выполнить с датчика случайных чисел заданы два двумерных массива размером 3 строки и 2 столбца. вычислить третий массив такого же размера, каждый элемент которого равен произведению соответствующих элементов двух первых массивов, уменьшенному в 10 раз. все массивы вывести

Информатика

Ответы

алексей-Ветошкин
// PascalABC.NET 3.1, сборка 1250 от 28.05.2016
begin
  var a:=MatrixRandom(3,2,-99,99);
  Writeln('Массив А');
  for var i:=0 to 2 do begin
    for var j:=0 to 1 do Write(a[i,j]:4);
    Writeln
    end;
  var b:=MatrixRandom(3,2,-99,99);
  Writeln('Массив B');
  for var i:=0 to 2 do begin
    for var j:=0 to 1 do Write(b[i,j]:4);
    Writeln
    end;
  var c:array[0..2,0..1] of real;
  Writeln('Результирующий массив');
  for var i:=0 to 2 do begin
    for var j:=0 to 1 do begin
      c[i,j]:=a[i,j]*b[i,j]/10; Write(c[i,j]:7:1)
      end;
    Writeln
    end
end.

Тестовое решение
Массив А
 -91 -93
 -62   9
 -97   6
Массив B
 -64  18
  57 -34
 -65 -30
Результирующий массив
  582.4 -167.4
 -353.4  -30.6
  630.5  -18.0
Borisovich-Volobueva1803

Восхищаясь возможностями, которые несет информационное общество, не следует забывать о тех противоречиях, которые оно потенциально содержит и которые уже проявляются.

Следует понимать, что понятие “информационное общество” не лежит в том же круге понятий, которые связаны с понятиями “капитализм”, “социализм” и пр., т.е. не указывает напрямую на характер отношений собственности и экономический уклад. Точно так же его не следует воспринимать как очередную утопию, сулящую всеобщее счастье.

Перечислим некоторые опасности и проблемы на пути к информационному обществу:

· реальная возможность разрушения информационными технологиями частной жизни людей и организаций;

· опасность все возрастающего влияния на общество со стороны средств массовой информации и тех, кто эти средства контролирует;

· проблема отбора качественной и достоверной информации при большом ее объеме;

· проблема адаптации многих людей к среде информационного общества, к необходимости постоянно повышать свой профессиональный уровень;

· столкновение с виртуальной реальностью, в которой трудно различимы иллюзия и действительность, создает у некоторых людей, особенно молодых, мало изученные, но явно неблагоприятные психологические проблемы;

· переход к информационному обществу не сулит каких-либо перемен в социальных благах и сохраняет социальное расслоение людей; более того, информационное неравенство может добавиться к существующим видам неравенства и тем самым усилить социальную напряженность;

· сокращение числа рабочих мест в экономике развитых стран, не компенсируемое полностью созданием новых рабочих мест в информационной сфере, ведет к опасному социальному недугу — массовой безработице.

Крайним проявлением негативных последствий перехода к информационному обществу являются так называемые “информационные войны”. Этот термин трактуется как открытое или скрытое информационное воздействие государственных систем друг на друга с целью получения определенного выигрыша в политической или материальной сфере. Основными объектами поражения в таких войнах будут информационные инфраструктуры и психология противника.

Под информационной войной понимается комплексное воздействие на систему государственного и военного управления противостоящей стороны, на ее военно-политическое руководство. В принципе это воздействие должно еще в мирное время приводить к принятию благоприятных (для стороны — инициатора информационного давления) решений, а в ходе конфликта полностью парализовать функционирование инфраструктуры управления противника. Информационное противоборство, предшествующее информационной войне, реализуется путем воздействия на информацию и информационные системы противника с одновременным укреплением и защитой собственной информации и информационных систем и инфраструктуры. На определенном этапе информационная война может перейти в обычную, с применением традиционных видов оружия для подавления ослабленного противника. К сожалению, примеры состоявшихся информационных войн уже есть.

Объяснение:

adhotel
Function Otr(Ax, Ay, Bx, By: real): real;
begin
  Otr := sqrt(sqr(Ax - Bx) + sqr(Ay - By))
end;

function Perim(Ax, Ay, Bx, By, Cx, Cy: real): real;
begin
  Perim := Otr(Ax, Ay, Bx, By) + Otr(Bx, By, Cx, Cy) + Otr(aX, aY, Cx, Cy);
end;

function Area(Ax, Ay, Bx, By, Cx, Cy: real): real;
var
  pp: real;
begin
  pp := Perim(Ax, Ay, Bx, By, Cx, Cy) / 2;
  Area := sqrt(pp * (pp - Otr(Ax, Ay, Bx, By)) * (pp - Otr(Bx, By, Cx, Cy)) *
    (pp - Otr(Ax, Ay, Cx, Cy)))
end;

procedure Dist(Px, Py, Ax, Ay, Bx, By: real; var D: real);
begin
  D := 2 * Area(Px, Py, Ax, Ay, Bx, By) / Otr(Ax, Ay, Bx, By)
end;

var
  Px, Py, Ax, Ay, Bx, By, Cx, Cy: real;
  d: real;

begin
  writeln('Вводите координаты точкек парами чисел: ');
  write('P-> ');
  readln(Px, Py);
  write('A-> ');
  readln(Ax, Ay);
  write('B-> ');
  readln(Bx, By);
  write('C-> ');
  readln(Cx, Cy);
  writeln;
  Dist(Px, Py, Ax, Ay, Bx, By, d);
  writeln('Расстояние от Р до АВ равно ', d);
  Dist(Px, Py, Cx, Cy, Bx, By, d);
  writeln('Расстояние от Р до ВC равно ', d);
  Dist(Px, Py, Ax, Ay, Cx, Cy, d);
  writeln('Расстояние от Р до АC равно ', d)
end.

Тестовое решение:
Вводите координаты точкек парами чисел:
P-> -3 6
A-> 5 8
B-> 9 -4
C-> 8 -2.5

Расстояние от Р до АВ равно 8.22192191643778
Расстояние от Р до ВC равно 4.43760156980184
Расстояние от Р до АC равно 8.24163383692135

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Срешить , составить программу в паскаль и выполнить с датчика случайных чисел заданы два двумерных массива размером 3 строки и 2 столбца. вычислить третий массив такого же размера, каждый элемент которого равен произведению соответствующих элементов двух первых массивов, уменьшенному в 10 раз. все массивы вывести
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Альберт Татьяна
Виктория Нина
ilyatamurov
ЭдуардовнаКлючников1361
Алина Ракитин1730
Шмидт Ирина
jagerlayf
marketing601
pokrov777krest
martabunova
Alex17841
sergeychelyshev197618
girra
marketing601
Yelena642