Nadirovich1317
?>

Можете , на языке turbopascal: 4)определить значение z = max (a, 2b) • max (2a-b, b), где max (x, y) есть максимальное из чисел х, у. при peшении определить и использовать функцию max.выполнить отладку программы с заходом в каждую из подпрограмм. 5)найти сумму четных элементов массива целых чисел. массив должен вводится во время работы программы.выполнить отладку программы с заходом в каждую из подпрограмм. 6)написать программу вычисления произведения положительных элементов двумерного массива целых чисел.

Информатика

Ответы

Маргарита595
4)
var
    a, b: integer;

function max(a, b: integer): integer;
begin
    if a > b then max := a else max := b;
end;

begin
    readln(a, b);
    writeln(max(a, 2 * b) * max(2 * a - b, b));
end.

5)
const
    n = 10;

var
    a: array[1..n] of integer;
    i, s: integer;

begin
    for i := 1 to n do
    begin
        readln(a[i]);
        if i mod 2 = 0 then s := s + a[i];
    end;
    writeln(s);
end.

6)
const
    handsfree = false;

var
    a: array[1..100, 1..100] of real;
    product: real;
    i, j, m, n: integer;

begin
    {ввод матрицы}
    if handsfree then begin
        n := random(20) + 2;
        m := random(20) + 2;
    end
    else begin
        write('n, m =');
        readln(n, m);
    end;
    
    writeln('Данные матрицы:');
    for i := 1 to m do
    begin
        for j := 1 to n do
            if handsfree then begin
                a[i, j] := random(100) - 50;
                write(a[i, j]:4, ' ')
            end
            else
                read(a[i, j]);
        writeln;
    end;
    
    product := 1;
    for i := 1 to m do
        for j := 1 to n do
            if a[i, j] > 0 then
                product := product * a[i, j];
    writeln('product = ', product);
end.
aa276568
2-хранение информации
3- ввода: клавиатура, мышь, сканер 
вывода: монитор, калонки, принтер
4-в двоичном коде
5-это часть системы компьютерной памяти, в которой временно хранятся данные и команды, необходимые процессору для выполнения им операции
6- это память, предназначенная для длительного хранения программ и данных
7- комплекс взаимосвязанных программ, предназначенных для управления ресурсами компьютера и организации взаимодействия с пользователем.
8-однозадачные операционные системы позволяют в каждый момент времени решать только одну задачу. Такие системы обычно позволяют запустить одну программу в основном режиме.
9-многозадачные системы позволяют запустить одновременно несколько программ, которые будут работать параллельно.
10- единица измерения количества информации.
11- это наука о и методах представления, обработки, передачи и хранения информации с ЭВМ
12- главный вычислительный элемент компьютера
13- совокупность программ системы обработки информации и программных документов, необходимых для эксплуатации этих программ.
asi19776
var s,k: integer;
// описали переменные, которые будут использованы в программе: s и k целые числа
begin
s:= 500;
// переменной s присвоили начальное значение 500
for k:= 4 to 10 do
// организовали цикл для k от 4 до 10 с шагом 1. То есть нижеследующий оператор цикла будет выполняться 7 раз (для k=4, k=5, k=6, ... k=10)
s:= s - 2*k;
// для каждого k поочередно считаем s:
// k=4   --   s=500-2*4=492
// k=5   --   s=492-2*5=482
// k=6   --   s=482-2*6=470
// k=7   --   s=470-2*7=456
// k=8   --   s=456-2*8=440
// k=9   --   s=440-2*9=422
// k=10 --   s=422-2*10=402
write (s);
// выводим на экран итоговое значение s: 402
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Можете , на языке turbopascal: 4)определить значение z = max (a, 2b) • max (2a-b, b), где max (x, y) есть максимальное из чисел х, у. при peшении определить и использовать функцию max.выполнить отладку программы с заходом в каждую из подпрограмм. 5)найти сумму четных элементов массива целых чисел. массив должен вводится во время работы программы.выполнить отладку программы с заходом в каждую из подпрограмм. 6)написать программу вычисления произведения положительных элементов двумерного массива целых чисел.
Ваше имя (никнейм)*
Email*
Комментарий*