Aleksandr_Vasilev
?>

Решить, в паскале, 1.найти первый положительный элемент массива, величина которого, больше заданной величины, заменить его обратной величиной и поменять местами со вторым элементом. 2.в каждом слове определить количество цифр

Информатика

Ответы

pokupatel688
//Pascal ABC.NET 3.1 сборка 1219

//1
Const
 n=10;

Var
 ar:array[1..n] of integer;
 i,c:integer;
begin
 randomize;
 readln(c);
  writeln('Array:');
  for i:=1 to n do
   begin
    ar[i]:=random(-10,10);
    write(ar[i]:4);
   end;
 for i:=1 to n do
  if (ar[i]>0) and (ar[i]>c) then
   begin
    ar[i]:=-ar[i];
    swap(ar[i],ar[2]);
    break;
   end;
 writeln;
 writeln('Final array:');
 for i:=1 to n do
 write(ar[i]:4);
end.

//2
Var
 se:set of char;
 s:string;
 i,j,k:integer;
begin
se:=['0','1','2','3','4','5','6','7','8','9'];
readln(s);
var ars:=s.Split;
for i:=0 to ars.Length-1 do
begin
 for j:=1 to length(ars[i]) do
  if ars[i][j] in se then inc(k);
writeln(ars[i],':',k);
k:=0;
end;
end.
uglichwatch
Файл размером 100 Кбайт передаётся через некоторое соединение со скоростью 1536 бит в секунду. Определите размер файла (в Кбайт), который можно передать за то же время через другое соединение со скоростью 768 бит в секунду. В ответе укажите одно число – размер файла в Кбайт. Единицы измерения писать не нужно.1. 100×1024×8=819200 бит. 2. t=819200бит/1536бит/сек=533сек.3. 533сек×768битсек=409344бит.4. 409344/8=51168байт.5. 51168байт/1024=50Кбайт. Я советую тебе проверить, правильно ли ты написал (а) числа, ибо ответ не целый много, где получается. Так как время одинаковое, легче решать пропорцией.
100 Кбайт : 1536 бит в секунду = х Кбайт / 768 бит в секунду
х Кбайт = 100 Кбайт × 768 бит в секунду / 1536 бит в секунду = 100 К байт / 2 = 50 Кбайт
Borshchev1820
Самый первый компьютер в мире Марк 1

Самый первый компьютер в мире был создан и построен в США математиком из Гарвардского университета Говардом Эйксном еще в 1941 году. После всех испытаний, состоялся его запуск седьмого августа 1944. Он получил название от своих создателей «Марк 1», и его поставили работать в Гарварде.


Тогда этот компьютер стоил пятьсот тысяч долларов, баснословная по тем временам сумма. Его собрали в специальный корпус, который был сделан из стекла и стали, не поддающейся коррозии. Сам корпус в длину был не менее семнадцати метров, высота была более 2.5 м. Его масса была около 5-ти тонн и занимал он пространство объемом в несколько десятков кубических метров.
«Марк 1» состоял из множества переключателей и прочих механизмов, общая численность которых составляла 765 тысяч.
Его провода составляли общую длину около восьмисот километров!Машина могла:

1) оперировать семьюдесятью двумя числами, которые в свою очередь состояли из двадцати трех десятичных разрядов
2) компьютер мог вычитать, складывать и на каждую из операций у него уходило по три секунды.
3) кроме этого, он также умножал и делил, тратя на эти операции по шесть и пятнадцать секунд.

Выбери самое важное. У меня всё

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить, в паскале, 1.найти первый положительный элемент массива, величина которого, больше заданной величины, заменить его обратной величиной и поменять местами со вторым элементом. 2.в каждом слове определить количество цифр
Ваше имя (никнейм)*
Email*
Комментарий*