Иванович-Васильевна1153
?>

Дана целочисленная прямоугольная матрица. найти сумму элементов тех столбцов, которые содержат хотя бы один отрицательный элемент. примечание: размеры массивов именованными константами. значения элементов массивов вводятся с клавиатуры, генерируются случайным образом или инициализируются в программе (значения по умолчанию элементов массива выбирается пользователем. все операции над массивами выполняются отдельными функциями.

Информатика

Ответы

fomindmity1
//Pascal ABC.NET 3.1 сборка 1219

Const
 n=3; m=4;

Var
 ma:array[1..n,1..m] of integer;
 arsub:array[1..m] of boolean;
 i,j,s:integer;
begin
randomize;
writeln('Matrix:');
for i:=1 to n do
 begin
  for j:=1 to m do
   begin
    ma[i,j]:=random(-2,10);
    write(ma[i,j]:4);
    if ma[i,j]<0 then arsub[j]:=true;
   end;
  writeln;
 end;
for j:=1 to m do
 if arsub[j]=true then
  for i:=1 to n do
   s:=s+ma[i,j];
writeln('Res=',s);
end.

Пример работы программы:
Matrix:
   2  -2   9   9
   0   9  10   1
   4   9  -1   3
Res=34
JisesLove19955

перо Сместиться в точку (1,7) Сместиться в точку (1,5) Поднять перо Сместиться на вектор (0,-2) Опустить перо Сместиться на вектор (2,0) Сместиться в точку (3,5) Сместиться на вектор (-2,0) Поднять перо Сместиться в точку (4,5) Опустить перо Сместиться на вектор (2,0) Поднять перо Сместиться в точку (5,6) Опустить перо Сместиться в точку (5,4) Поднять перо Сместиться в точку (7,3) Опустить перо Сместиться на вектор (2,0) Сместиться на вектор (0,4) Сместиться в точку (7,7) Сместиться в точку (7,5) Сместиться в точку (9,5) Поднять перо В ответе укажите только число, без пробелов и каких-либо знаков препинания, например 100 ответ:

Объяснение:

irinalav2705745

Объяснение:

const

 n = 10;

 ar:array[1..n] of integer = (-2, -1, 2, 3, 4, 5, -5, -6, 2, 5);

var

 i:integer;

 is_first_pol:boolean;

 raz_pol:integer;

begin

 

 raz_pol:=0;

 is_first_pol:=true; // флаг того, что найденное положительное число - первое

 

 for i:=1 to n do begin

   

   if (ar[i] > 0) then

     

     if (is_first_pol) then begin

       // если найденное полодительное число - первое, то

       raz_pol:=ar[i]; // в нашу разницу заносим это число

       is_first_pol:=false; // меняем флаг

     end

     else raz_pol:=raz_pol - ar[i]; // иначе вычисляем разницу

 

 end;

 

 writeln(raz_pol);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана целочисленная прямоугольная матрица. найти сумму элементов тех столбцов, которые содержат хотя бы один отрицательный элемент. примечание: размеры массивов именованными константами. значения элементов массивов вводятся с клавиатуры, генерируются случайным образом или инициализируются в программе (значения по умолчанию элементов массива выбирается пользователем. все операции над массивами выполняются отдельными функциями.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

hbqhzwtd
shangina1997507
inj-anastasia8
Kamil
gip5362
KononovaMaiorov453
annino
laktionova-natal
stairov536
rezh2009766
shyroshka836103
Marina658
rusvicktor
kmr495270
elena-ppk
▲