agusarevich283
?>

Напишите программу, которая определяет, является ли введенное число четным и больше 100.

Информатика

Ответы

elenaowchinik4842
//Скучно
//Pascal ABC.NET 3.1 сборка 1256

Var
 a:integer;
begin
readln(a);
if (a>100) and (not(odd(a))) then writeln('Да') else writeln('Нет');
end.

Пример ввода:
128
Пример вывода:
Да
dyatchina63
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var n:=ReadInteger('Введите натуральное число:');
  if n.IsEven and (n>100) then Writeln('Число четное и больше ста')
  else Writeln('Неверно, что число четное и больше ста')
end.

Тестовое решение
Введите нетуральное число: 146
Число четное и больше ста

Введите натуральное число: 38
Неверно, что число четное и больше ста

Введите натуральное число: 101
Неверно, что число четное и больше ста
vera-spicina

Если вы часто работаете в MS Word, сохранение документа в качестве шаблона наверняка вас заинтересует. Так, наличие шаблонного файла, с установленным вами форматированием, полями и прочими параметрами, может во многом упростить и ускорить рабочий процесс. 

Шаблон, создаваемый в ворде, сохраняется в форматах DOT, DOTX или DOTM. Последний разрешает работу с макросами. Шаблон — это особый тип документа, при его открытии и последующем изменении создается копия файла. Исходный (шаблонный) документ при этом остается неизменным, как и его местоположение на диске. В качестве примера того, каким может быть шаблон документа и зачем вообще он нужен, можно привести бизнес-план. Документы этого типа довольно часто создаются в Word, следовательно, используют их тоже довольно часто.

Так, вместо того, чтобы каждый раз заново создавать структуру документа, выбирать подходящие шрифты, стили оформления, устанавливать размеры полей, можно просто использовать шаблон со стандартным макетом. Согласитесь, такой подход к работе куда более рационален. Документ, сохраненный в качестве шаблона, можно открыть и заполнить необходимыми данными, текстом. При этом, сохраняя его в стандартных для Word форматах DOC и DOCX, исходный документ (созданный шаблон), будет оставаться неизменным, как уже было сказано выше.

Создание собственного шаблона

Проще всего будет начать создание шаблона с пустого документа, для открытия которого достаточно просто запустить Word.

SEMENOV25352

Если вы часто работаете в MS Word, сохранение документа в качестве шаблона наверняка вас заинтересует. Так, наличие шаблонного файла, с установленным вами форматированием, полями и прочими параметрами, может во многом упростить и ускорить рабочий процесс. 

Шаблон, создаваемый в ворде, сохраняется в форматах DOT, DOTX или DOTM. Последний разрешает работу с макросами. Шаблон — это особый тип документа, при его открытии и последующем изменении создается копия файла. Исходный (шаблонный) документ при этом остается неизменным, как и его местоположение на диске. В качестве примера того, каким может быть шаблон документа и зачем вообще он нужен, можно привести бизнес-план. Документы этого типа довольно часто создаются в Word, следовательно, используют их тоже довольно часто.

Так, вместо того, чтобы каждый раз заново создавать структуру документа, выбирать подходящие шрифты, стили оформления, устанавливать размеры полей, можно просто использовать шаблон со стандартным макетом. Согласитесь, такой подход к работе куда более рационален. Документ, сохраненный в качестве шаблона, можно открыть и заполнить необходимыми данными, текстом. При этом, сохраняя его в стандартных для Word форматах DOC и DOCX, исходный документ (созданный шаблон), будет оставаться неизменным, как уже было сказано выше.

Создание собственного шаблона

Проще всего будет начать создание шаблона с пустого документа, для открытия которого достаточно просто запустить Word.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая определяет, является ли введенное число четным и больше 100.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Apresov
daverkieva568
evada2
semenoffufc8
fmba18
NatalyaAlekseevich1644
Struev730
dirzhanov683
ИП_Рамис873
dushechkin2
Olga-Borisovna
Константин
I.B.Petrishchev
Aleksandr740
gassvetlana
▲