I.B.Petrishchev
?>

Мне нужно ответь составить программу, которая бы запрашивала хнач , хкон , шаг c и определяла сумму всех отрицательных чисел от хнач до хкон с шагом с (решить , используя цикл с постусло-вием – repeat … until

Информатика

Ответы

yanermarina87
//Pascal ABC.NET 3.1 сборка 1256

Var
 n,k,c,s,kar:real;
 i:integer;
begin
read(n,k,c);
i:=0;
s:=0;
kar:=n;
repeat
if n<0 then s:=s+n;
inc(i);
n:=kar+i*c;
until n>k;
writeln(s);
end.

Пример ввода:
-3
1
1.1
Пример вывода:
-5.7

Мне нужно ответь составить программу, которая бы запрашивала хнач , хкон , шаг c и определяла сумму
Шиловский126
//PascalABC.Net 3.0, сборка 1064
type
  IntArray = array of integer;

var
  rows, cols: integer;
  M: array of IntArray;

begin
  Write('Количество строк и столбцов матрицы: '); Read(rows, cols);
  var Avg: array of double := new double[cols];
  M := new IntArray[rows];
  SetLength(Avg, cols);
  for var i := 0 to rows - 1 do
  begin
    M[i] := ArrRandom(cols, -25, 25);
    M[i].Println(#9)
  end;
  for var j := 0 to cols - 1 do
    Avg[j] := Range(0, rows - 1).Select(x -> M[x, j]).Average;
  Writeln('Наименьшее среднее по столбцам равно ', Avg.Min)
end.

Тестовое решение:
Количество строк и столбцов матрицы: 5 8
-22    -8    12    7    3    -18    8    22
2    -16    17    -13    -10    0    -19    2
20    -21    -6    13    2    -20    25    24
-7    -3    -2    -10    -2    8    18    23
4    -21    -8    8    23    -12    -13    -5
Наименьшее среднее по столбцам равно -13.8
magazintrofey

1)Что такое поле БД?  (ответ) Поле базы данных - это столбец таблицы, содержащий значения определенного свойства. Строки таблицы являются записями об объекте; эти записи разбиты на поля столбцами таблицы, поэтому каждая запись представляет собой набор значений, содержащихся в полях.

2) Для чего нужно связывать таблицы в БД?

(ответ) Многие СУБД при связывании таблиц автоматически выполняют контроль целостности вводимых в базу данных в соответствии с установленными связями. В конечном итоге это повышает достоверность хранимой в БД информации.

3)  Что такое База данных? (ответ) представленная в объективной форме совокупность самостоятельных материалов, систематизированных таким образом, чтобы эти материалы могли быть найдены и обработаны с электронной вычислительной машины

4)В каком режиме могут создаваться поля БД?

(ответ)

*создание таблицы в режиме конструктора;

*создание таблицы с мастера;

*создание таблицы путем ввода данных

5)  Если между таблицами БД установлены связи, то к чему может привести  изменение или удаление существующих полей? (ответ) Каждая запись в таблице "Сведения о заказах" содержит значение поля "КодТовара", которому соответствует запись в таблице "Товары" с тем же значением в данном поле. тут не уверен честно

6) Что такое ключевое поле БД?  (ответ)Ключевое поле — это одно или несколько полей, комбинация значений которых однозначно определяет каждую запись в таблице. Если для таблицы определены ключевые поля, то Microsoft Access предотвращает дублирование или ввод пустых значений в ключевое поле.

7) Назовите два основных этапа создания БД (ответ) Определить структуру базы данных и типа каждого поля. 2. Ввод данных. ... Поиск информации в базе данных на основе критериев поиска

8)При чего можно создать формы ввода данных в таблицу

(ответ)

инструмента Form;

инструмента Разделенная form;

инструмента Несколько элементов;

инструмента Пустая form;

Мастера form;

Конструктора form.

9)Приведите примеры типов полей (из разобранного видеоматериала)

(ответ) Каждая таблица в Access состоит из полей. В свойствах поля описываются характеристики и поведение добавляемых в него данных. Тип данных поля — это самое важное свойство, которое определяет, какие данные могут храниться в поле. В этой статье описаны типы данных и другие свойства поля, доступные в Access, а также приведена дополнительная информация в разделе справочных сведений о типах данных.

10)Приведите примеры типов полей из разобранного видеоматериала (ответ) Каждая таблица в Access состоит из полей. В свойствах поля описываются характеристики и поведение добавляемых в него данных. Тип данных поля — это самое важное свойство, которое определяет, какие данные могут храниться в поле. В этой статье описаны типы данных и другие свойства поля, доступные в Access, а также приведена дополнительная информация в разделе справочных сведений о типах данных.

11)Опишите тип поля счетчик своими словами (ответ) новое поле предназначенное для хранения часто изменяющихся целочисленных данных

12)Из каких файлов можно импортировать данные в таблицу БД? (ответ) импортировать таблицы, за формы, отчеты, макросы и модули из одной базы данных Access в другую. При импорте Access создает копию объекта в текущей базе данных.

(вроде всё!)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Мне нужно ответь составить программу, которая бы запрашивала хнач , хкон , шаг c и определяла сумму всех отрицательных чисел от хнач до хкон с шагом с (решить , используя цикл с постусло-вием – repeat … until
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Faed_Arakcheeva
Сорокина
ckati
osherbinin
aobuhta4
ba5-m
Матвеев
tatyana58
VladimirovnaKashintsev1151
Как выделяется тело документа?
martabunova
Виктор Попова
bd201188
ekasatkina
droshchupkin
алексеевич810