ответ:
алгоритм- это конечная совокупность точно заданных правил решения произвольного класса или набор инструкций, описывающих порядок действий исполнителя для решения некоторой . в старой трактовке вместо слова «порядок» использовалось слово «последовательность», но по мере развития параллельности в работе компьютеров слово «последовательность» стали заменять более общим словом «порядок». независимые инструкции могут выполняться в произвольном порядке, параллельно, если это позволяют используемые исполнители.
ранее в языке писали «алгорифм», сейчас такое написание используется редко, но, тем не менее, имеет место исключение (нормальный алгорифм маркова).
часто в качестве исполнителя выступает компьютер, но понятие алгоритма необязательно относится к компьютерным программам, так, например, чётко описанный рецепт приготовления блюда также является алгоритмом, в таком случае исполнителем является человек (а может быть и некоторый механизм, ткацкий станок, и
можно выделить алгоритмы вычислительные (о них в основном идет далее речь), и . вычислительные по сути преобразуют некоторые начальные данные в выходные, реализуя вычисление некоторой функции. семантика алгоритмов существенным образом может отличаться и сводиться к выдаче необходимых воздействий либо в заданные моменты времени, либо в качестве реакции на внешние события (в этом случае, в отличие от вычислительного алгоритма, может оставаться корректным при бесконечном выполнении).
понятие алгоритма относится к первоначальным, основным, базисным понятиям . вычислительные процессы алгоритмического характера (арифметические действия над целыми числами, нахождение наибольшего общего делителя двух чисел и т. д.) известны человечеству с глубокой древности. однако в явном виде понятие алгоритма сформировалось лишь в начале xx века.
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу, которая бы запрашивала хнач и хкон и определяла произведение всех положительных чисел от хнач до хкон (решить , используя цикл с предусловием – while .. do пож
Var
xk,xn:real;
i,r,xik,xin:integer;
b:boolean;
begin
b:=false;
r:=1;
read(xn,xk);
xin:=round(xn-frac(xn));
xik:=round(xk-frac(xk));
i:=xin;
while i<=xik do
begin
if i>0 then
begin
r:=r*i;
b:=true;
end;
inc(i);
end;
if b=true then write(r) else write('0');
end.
Пример ввода:
-2.8
3.8
Пример вывода:
6