avon-central
?>

Пож . составить программу, запрашивающую у пользователя дату в кратком формате дд.мм.гг (например: 15.10.2012), и отображающую эту дату в полном формате (например: 15 октября 2012 года

Информатика

Ответы

nestruev
//Pascal ABC.NET 3.1 сборка 1256

Var
 ars:array[1..12] of string:=('января','февраля','марта','апреля','мая','июня','июля','августа','сентября','октября','ноября','декабря');
 s:string;
begin
read(s);
if s[1]='0' then delete(s,1,1);
write(copy(s,1,pos('.',s)-1),' ');
delete(s,1,pos('.',s));
write(ars[strtoint(copy(s,1,pos('.',s)-1))],' ');
delete(s,1,pos('.',s));
write(s,' года');
end.

Пример ввода:
15.10.2012
Пример вывода:
15 октября 2012 года
leeka152522
1. 4 шага:
          35        56
1)       35        21
2)       14        21
3)       14         7
4)        7          7

2. Кораблик (см. фото)

3. 

Исходная цепочка                ЛОМ
         1-й шаг                         ЛОМ
         2-й шаг                         ЛОММОЛ
         3-й шаг                         ЛОММОЛН
         4-й шаг                         ЛОММОЛН
         5-й шаг                         ЛОММОЛННЛОММОЛ
         6-й шаг                         ЛОММОЛННЛОММОЛО
         Результат                     ЛОММОЛННЛОММОЛО
Количество букв «О»           5

4.

Исходная цепочка            КОЛ
        1-й шаг                      Л
        2-й шаг                      ЛЛО
        3-й шаг                      ЛЛОК
       Результат                   ЛЛОК

5.

Номер строки          Строка
          1                          1
          2                         21
          3                        312
          4                       4213
          5                      53124
          6                     642135
..............
9-я строка будет оканчиваться на четные цифры от 8 вниз 2468
1. имеются две кучки фишек. за один шаг исполнитель нод из кучки, содержащей больше фишек, убирает с
zodgener

будет выведено значение k, равное 24

Объяснение:

изначально s будет равно 25, функция mod - остаток от деления

здесь у нас цикл с условием выполнения, если s будет делиться на 2 без остатка (т.е. остаток будет равен нулю)

в первом случае (когда s=25) у нас получается остаток 1, идем по циклу, получаем s=24 (т.к. s присваивается значение s-1, т.е. 25-1=24) и k=s/2=24/2=12

далее если идти по циклу с s=24, получаем остаток 0 (24/2=12 - целое число без остатка)

по условию цикла получаем k=24 (если остаток 0, то значение s присваиваем k)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Пож . составить программу, запрашивающую у пользователя дату в кратком формате дд.мм.гг (например: 15.10.2012), и отображающую эту дату в полном формате (например: 15 октября 2012 года
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

masamosijcuk140244
Елена-Олег
bg1967bg
Zhanibekrva Kandaurova
knigi21212
kosstroy
goldglobustour725
Shikhova-Vitalii1290
impuls20125948
Akolomaeva4
windless-el
anitanemtsewa
picsell
Tuzov
dimon198808744
▲