Shitikov-M.A.1307
?>

Написать программу пользователь вводит число, проверить извлекается ли из этого числа корень

Информатика

Ответы

galkar
Исходник на c++. Реализовал функцию, которая проверяет, является ли целое число полным квадратом. В функции main() приведен пример ее использования. То есть если число полный квадрат, выводится "Yes.", иначе "No.". Числа, которые можно проверять, имеют тип long long, то есть попадают в диапазон от -2^63 до 2^63-1. Думаю, сильно большие числа проверять ты не станешь, поэтому этого диапазона с лихвой хватит.
alina Korneev

Ну, во-первых, мы знаем, что в  1 байт это 8 бит, отсюда следует, что  1 килобайт это 1024 байт.

 2048 бит = 2048 / 8 = 256 байт


   256 байт = 256 / 1024 = 0,25 Кбайт

0,25 Кбайт/с это получается сокрость соединения

Скорость соединения 0,25 Кбайт/сек.

Это мы перевели скорость 1-ого соединения из бит/с в кбайт/с

24 / 0,25 = 96 секунд.

Это мы определили время пути файла 24 Кбайт

   512 * 96 = 49152 биты


    49152 бит = 49152 / 8 = 6144 байт


    6144 байт = 6144 / 1024 = 6 Кбайт.

Так мы определили размер фала в Кбайтах, его можно передать за 96 секунд, соответсвенно через соединение со скоростью 512

ответ: 6 Кбайт.

Если что-то неправильно, приношу извинения. )))

Полковников_Милана

#define _CRT_SECURE_NO_WARNINGS

#include <iostream>

#include <ctime>

using namespace std;

int main()

{

 int y;

 char buffer[80];

 cout << "Year = ";

 cin >> y;

 tm time_in;

 time_in.tm_sec = 0;  // second

 time_in.tm_min = 0;  // minute

 time_in.tm_hour = 0; // hour

 time_in.tm_mday = 1; // 1-based day

 time_in.tm_mon = 9;  // 0-based month

 time_in.tm_year = y - 1900; // year since 1900

 time_t time_temp = mktime (&time_in);   // Convert the local time to a calendar value.

 tm* time_out = localtime (&time_temp);  // Converts a time_t time value to a tm structure

 if (time_out->tm_wday > 0)              // if it is not Sunday, go to the next Sunday

   time_out->tm_mday += 7 - time_out->tm_wday;

 

 strftime(buffer, 80, "%d.%m.%Y", time_out);  // date formatting for output

 cout << "\nTeachers day is " << buffer << "\n";

}

Объяснение: explanations in the comments to the program

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу пользователь вводит число, проверить извлекается ли из этого числа корень
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

uisfbu7777733
dilbaryan76
abuley
ktv665
qwert28027170
klimenokvapeshop1408
langprint
Maloletkina-marina2
maximovpavel9114
Femida76
vainshakov
artemkolchanov24
dimaproh
amaraks67
edelstar83