tashovairina
?>

Написать программу, которая находит сумму, произведения, частное и разность 2 целых чисел. эти числа вводятся с клавиатуры.

Информатика

Ответы

fednik3337923
Program prog;
Uses crt;

var a,b: integer;

begin
clrscr;

write('A = ');
readln(a);
write('B = ');
readln(b);

writeln;
writeln(a, '+', b,'=',a+b);
writeln(a, '-', b,'=',a-b);
writeln(a, '*', b,'=',a*b);
writeln(a, '/', b,'=',(a/b):0:3);
end.
nekataniyoleg
Если число 49 записывается как 121, значит первый остаток от деления равен 1, то есть основанием системы счисления является число, кратное 48.

121 имеет 3 разряда, значит основание однозначно меньше 10 и больше 2. Подходят 3, 4, 6, 8.

Учитывая, что в числе 121 три разряда, значит число 48 делилось всего три раза. 
Число 8 не подойдет, т.к. 48/8=6, значит будет всего два деления.
Число 3 не подойдет, т.к. 48/3 = 16, 16/3=5 - то есть тут будет больше трёх знаков.
Число 4 не подойдет, т.к. 48/4=12, а 12 делится на 4 без остатка, но, судя по числу, во втором делении остаток должен быть равен 2.
Остаётся число 6. Проверим

49/6=8 |1
8/6 = 1 |2
1/6=0 |1

121(6)
GALINAMTO
9 килобайт = 9216 байт.
Зная информационный объём рассказа и количество страниц, найдём информационный объём одной страницы. В условии сказано, что каждый символ кодируется 8 битами, т.е. одним байтом. Также мы знаем количество символов в одной строке. Умножив 1 байт на количество символов в строке, найдём информационный объём одной строки. И, наконец, разделив информационный объём страницы на информационный объём строки, найдём количество строк на странице.

1) 9216 : 6 = 1536 (байт) – информационный объём одной страницы.

2) 1 × 48 = 48 (байт) – информационный объём одной строки.

3) 1536 : 48 = 32 (стр.) – количество строк на каждой странице.

ответ: на каждой странице помещается 32 строки.

ПРАВИЛЬНЫЙ ОТВЕТ – 3) 32

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая находит сумму, произведения, частное и разность 2 целых чисел. эти числа вводятся с клавиатуры.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

AndreevManaeva
mihalewanadia20176987
Герасименко
виталийВячеславович
Татьяна_Вологжин
Umkatoys50
anna241273
maglevanyycpt
olechka197835
ViktorovnaKraeva634
Yurevna-Anatolevna
Demina-Khokhlov584
victoriadan
edvard-b
myatadinamo