Алёна Геннадьевна98
?>

какие из описаний могут быть именами переменных a) с b) summa 2 c) book d) 2_а 2) какая команда служит для вывода значений переменных в pascal-е? пример. 3) найдите и исправьте ошибки в следующей программе: program prim_a; var m, n, k: integer; begin writeln(введите значения переменных m и n); read(m, n, k); writeln('(m+n+k)*5'); end. 4) напишите программу для решения одной из двух : a) найти площадь треугольника с основанием а и высотой h. b) найти значение выражения: 5) напишите программу для нахождения произведения цифр двузначного числа.

Информатика

Ответы

Vladimirovna1997
1. a; c
2. write(); writeln(). Пример: write(c) /поясняю: ln добавляется для перехода на следующую строку при выводе/
3. Ошибка - в строке "writeln(введите значения переменных m и n);" не указана переменная k. Так же не нужны кавычки в выводе, а при вводе необходимы.
Исправление:
program prim_a;
var m, n, k: integer;

begin
writeln('введите значения переменных m, n и k');
read(m,n, k);
writeln((m+n+k)*5);
end.
4. a) 
program plowad;
var
a, h: real;

begin
writeln('Введите основание треугольника и высоту');
readln(a, h);
writeln('Площадь треугольника равна ', a*h/2);
end.
5. program proizvedenie;
var 
a, b: integer;

begin
writeln('Введите двузначное число');
readln(a);
b:=a mod 10;
a:=a div 10;
writeln('Произведение цифр двузначного числа равно ', a*b);
end.
KononovaMaiorov453

Задание 1

#include <iostream>

using namespace std;

int main() {

int a, b;

cin >> a >> b;

cout << a - b;

}

Задание 2

#include <iostream>

#include <math.h>

using namespace std;

int main() {

int a;

cin >> a;

cout << pow(a, 2) << ' ' << pow(a, 3)<< ' ' << pow(a, 5);

}

Задание 3

#include <iostream>

#include <math.h>

using namespace std;

int main() {

int a;

cin >> a;

cout << "The next number for the number " << a << " is " << a + 1 <<"!\n" <<"The previous number for the number "<< a << " is " << a - 1 <<"!";

}

Задание 4

#include <iostream>

#include <math.h>

using namespace std;

int main() {

int a;

cin >> a;

cout << (3 * pow(a, 3) + 18 * pow(a, 2)) * a + 12 * pow(a, 2) - 5;

}

Задание 5

#include <iostream>

#include <math.h>

using namespace std;

int main() {

int a, b, c;

cin >> a >> b >> c;

cout << a % 7 << "\n" << b % 7 << "\n" << c % 7;

}

Задание 6

#include <iostream>

#include <math.h>

using namespace std;

int main() {

int a, b, c, a1, b1, c1;

cin >> a >> a1 >> b >> b1 >> c >> c1;

cout << a1 % (8 - a) << "\n" << b1 % (8 - b) << "\n" << c1 % (8 - c);

}

Espivak
1)
 var 
n:integer;
begin 
readln(n); 
if(n<0)then write(0) 
else write(n+4);
end.

2)
 var
  a, b: integer;
 begin
  readln(a, b);
  if(a = b) then
write(1)
  else
write(0);
end.

3)
var
  a, b, c, s: integer;
 begin
  s := 0;
  readln(a, b, c);
  if(a >= 0) then s := s + 1;
  if(b >= 0) then s := s + 1;
  if(c >= 0) then s := s + 1;
  write(s);
end.

4)
var
  a, b, c, s: integer;
 begin
  s := 0;
  readln(a, b, c);
  if(a > 0) then s := s + a;
  if(b > 0) then s := s + b;
  if(c > 0) then s := s + c;
  write(s);
end.
5)
 var
  a, b, c: integer;
 begin
  readln(a, b, c);
  if (a < b) then swap(a, b);
  if (a < c) then swap(a, c);
  if (b < c) then swap(b, c);
  write(a, ' ', b, ' ', c);
end.

6)
 var n, k, s, i: integer;
 begin
  s := 0;
  readln(n, k);
  for i := 1 to n.ToString.Length do
  if(strtoint(n.ToString[i]) > k) then s := s + strtoint(n.ToString[i]);
  write(s);
 end.

7)
 var n, s, i: integer;
 begin
  s := 0;
  readln(n);
  for i := 1 to n do
    s := s + i;
  write(s);
 end.

9)
 var n, i: integer;
 begin
  readln(n);
  for i := n downto 1 do
  write(i);
 end.

12
 var
  n, i: integer;
  s: real;
 begin
  s := 0;
  readln(n);
  for i := n downto 1 do
  s:=s+(0.1*i);
    write(s);
 end.

13)
 var n, i: integer;
 begin
  readln(n);
  for i := 1 to n do
    write(sqr(i), ' ');
end.

14)
 var
  n, i, c: integer;
 begin
  i := 1;
  c := 0;
  readln(n);
  while (c <> n) do
  begin
    if(i mod 3 = 0) then begin write(i, ' ');c := c + 1; end;
    i := i + 1;
  end;
end.

15)
 var
  n, i, a: integer;
  c: real;
 begin
  i := 1;
  c := 0;
  readln(n);
  for i := 1 to n do
   begin
    read(a);
    c := c + a;
  end;
  write(c / n)
end.

16)
 var
  n, i, a: integer;
 begin
  i := 1;
  while true do
   begin
    read(a);
    if(a = 0) then break;
    n := n + 1;
  end;
  write(n)
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

какие из описаний могут быть именами переменных a) с b) summa 2 c) book d) 2_а 2) какая команда служит для вывода значений переменных в pascal-е? пример. 3) найдите и исправьте ошибки в следующей программе: program prim_a; var m, n, k: integer; begin writeln(введите значения переменных m и n); read(m, n, k); writeln('(m+n+k)*5'); end. 4) напишите программу для решения одной из двух : a) найти площадь треугольника с основанием а и высотой h. b) найти значение выражения: 5) напишите программу для нахождения произведения цифр двузначного числа.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Artyukhin545
ekatef45
Bologova Golovach1989
bogatskayaa
olgolegovnak
Стадник620
Джулия
soclive7762
di-bobkov1985
romashka17-90
evgeniy1988486
gusinica23
aureole6452
Gennadievna bessonov
mnn99